Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#5925 closed enhancement (fixed)

Changes in -wm setting cause non reproducable gdalwarp output with approximate transformer

Reported by: Even Rouault Owned by: warmerdam
Priority: normal Milestone: 2.0.0
Component: Algorithms Version: unspecified
Severity: normal Keywords: warp
Cc:

Description

When using gdalwarp with the approximate transformer (which is the default), the generated output file may change in subtle way, depending on the value of the -wm setting (or if SRC_FILL_RATIO_HEURISTICS warping option is set or disabled). This is due to the approximate transformer not being invoked with the same starting and ending points, due to the window of each target chunk not being the same, and consequently the interpolated values change.

One way to solve this is to round coordinates resulting from the approximate transformer. A new warping option, SRC_COORD_PRECISION, is added. Its value is in (fractional) pixel. The way it has been implemented, this reliably works only if SRC_COORD_PRECISION is at least 10 times the value of the error threashold (-et parameter of gdalwarp)

Change History (4)

comment:1 Changed 7 years ago by Even Rouault

Resolution: fixed
Status: newclosed

trunk r28917 "Warper: add a SRC_COORD_PRECISION warping option to help getting more reproducable output when -wm parameter changes (#5925)"

comment:2 Changed 7 years ago by Even Rouault

trunk r28918 "Warper: improve performance when SRC_COORD_PRECISION/error_threshold ratio is higher (#5925)"

comment:3 Changed 7 years ago by Even Rouault

trunk r28919 "Fix comment (#5925)"

comment:4 Changed 6 years ago by Even Rouault

Milestone: 2.02.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.