Opened 7 years ago

Closed 7 years ago

#5837 closed defect (fixed)

PG: cannot retrieve more than 500 features when using tables= option and ExecuteSQL()

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.11.2
Component: OGR_SF Version: 1.11.0
Severity: normal Keywords: pg
Cc:

Description

If retrieving features with GetNextFeature?() on a PostgreSQL connection with a tables= parameter on a layer result of a SQL request, and that there's a SRS attached, only the first 500 features are retrieved due to the defered resolving of the SRS.

This is a regression that appeared in GDAL 1.11.0

See thread http://lists.osgeo.org/pipermail/gdal-dev/2015-February/041011.html

Change History (1)

comment:1 Changed 7 years ago by Even Rouault

Resolution: fixed
Status: newclosed

Fixed in trunk (r28444) and branches/1.11 (r28445) "PG: fix regression that prevented to retrieve more than 500 features from a connection with tables= parameter and on a SQL result layer (#5837)"

Note: See TracTickets for help on using tickets.