Opened 7 years ago

Closed 7 years ago

#5609 closed defect (duplicate)

GDAL crashes trying to get statistics from GeoTIFF with *.aux dependency

Reported by: geojulien Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: 1.11.0
Severity: normal Keywords: gdalinfo, band statistics
Cc:

Description

Hi,

Running gdalinfo command with -stats option on a *.tiff wich has .aux dependency. I noticed this behavior with GDAL on Windows Windows-7-6.1.7601-SP1 64 bits.

Because of the file size, I put it on my GDrive : https://drive.google.com/folderview?id=0B7HkM4fgyPC7VFpiQW1DZkxmNjA&usp=sharing

Thanks for your wonderful wok on this great library! Julien M.

Attachments (1)

GDAL_Info_stats.PNG (100.6 KB) - added by geojulien 7 years ago.
Windows terminal

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Jukka Rahkonen

I can't repeat with GDAL 2.0.0dev, released 2014/04/16 My version is 64-bit version compiled with MSVC2010 and downloaded from http://gisinternals.com/sdk/PackageList.aspx?file=release-1600-x64-gdal-mapserver.zip

Could you repeat your test with gisinternals builds and report the exact version so we could test with same binaries than you?

comment:2 Changed 7 years ago by geojulien

Sorry, I thought specifying the version directly in the ticket was sufficient. I always use the stable version i.e. 1.11.0, 32 bits because of I prefer ensure the compatibility with my Python installation. When I've to install or upgrade my GDAL install n Windows, I follow this process: http://geotribu.net/node/636

So, I downloaded the last package from http://www.gisinternals.com/sdk/PackageList.aspx?file=release-1500-gdal-1-11-0-mapserver-6-4-1.zip I upgraded at the end of April more or less.

Thxs for your interest.

comment:3 Changed 7 years ago by Jukka Rahkonen

As you can see from gisinternals, GDAL can be compiled with different compilers and by looking at the PackageInfo? page you can see that GDAL can be compiled in thousands of different ways http://gisinternals.com/sdk/PackageInfo.aspx?file=release-1500-gdal-mapserver.zip Often bugs affect GDAL in a general level but sometimes it is necessary to know more details.

I downloaded this package http://www.gisinternals.com/sdk/Download.aspx?file=release-1500-gdal-1-11-0-mapserver-6-4-1.zip and tested gdalinfo and gdalinfo -stats with your 1999-116.tif with the .aux file in the same folder. I do not get a crash. My computer is running Windows 7 Enterprise SP1, 64-bit.

comment:4 Changed 7 years ago by Even Rouault

I've checked on Linux 64bit with trunk and 1.11 branch with the Valgrind memory detector in the case the error would be a memory corruption with random behaviour, but nothing shows up.

Julien, is it a systematic error on your side ? Could you try with other binaries on gisinternals ?

Changed 7 years ago by geojulien

Attachment: GDAL_Info_stats.PNG added

Windows terminal

comment:5 Changed 7 years ago by geojulien

Am I the only one facing this issue?

I tried it on other machine (Windows 8.1) where I installed the same binary package. Here is my GDAL version:

C:\Users\Risor>gdalinfo --version
GDAL 1.11.0, released 2014/04/16

So, I give you more history about this bug:

  • running gdalinfo without any problem.
  • With -stats option it crashes. (see screen capture above)
  • but if I delete the *.aux file, it works fine (and recreats an *.aux.xml file) and the next executions work fine too (except if I delete the *.aux.xml)
  • first time I found out this was running from Python bindings (here is my Python submodule) and it's very hard to describe:
    • crash is very specifically about bands stats because if I comment lines 255-279, there isn't any crash.
    • there is nor log and traceback, no exception to handle

I can try install another package but I think that it's important to understand this bug, isn't? I'll make a news install on my laptop (Windows 7) in next days.

Thanks for spending time on my trouble. Julien

comment:6 Changed 7 years ago by Even Rouault

Resolution: duplicate
Status: newclosed

After investigation, I could reproduce the issue with the official 1.11.0, but not with the 1.11 branch that has additional fixes. I've identified #5451 as being the fix for the symptom you observe. Using the -stable (instead of -release) package will fix the issue : http://www.gisinternals.com/sdk/PackageList.aspx?file=release-1500-gdal-1-11-mapserver-6-4.zip

Closing as duplicate of #5451

Note: See TracTickets for help on using tickets.