Opened 7 years ago

Closed 7 years ago

#5573 closed defect (duplicate)

gdalinfo segfaults with OpenJPEG 2.0.1/2.1.0

Reported by: reffettc Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 1.11.0
Severity: normal Keywords:
Cc:

Description

When reading in an ECRG image (such as the one attached) with gdalinfo when gdal-1.11.0 is built against OpenJPEG 2.0.1/2.1.0, it segfaults; the issue appears to be in file cpl_vsil.cpp, function VSIFTellL, crashes on "return poFileHandle->Tell();". There could be other compatibility issues with the new OpenJPEG releases (particularly 2.1.0, since it explicitly breaks the API). Changelogs and release notes for both versions can be found at https://code.google.com/p/openjpeg/.

Change History (5)

comment:1 Changed 7 years ago by reffettc

Sorry, my work firewall is preventing me from uploading the file, but you can use the ECRG image I attached to a previous report (http://trac.osgeo.org/gdal/attachment/ticket/5561/00000008cu00g3.es1) if you need a test file.

comment:2 Changed 7 years ago by Even Rouault

With 2.0.1 as well ? Woo, that's quite unexpected that a bugfix version would cause such breakage.

comment:3 Changed 7 years ago by reffettc

Yeah, I was expecting 2.0.1 to work too, but it segfaults in the same place. Strange.

comment:4 Changed 7 years ago by reffettc

Actually, disregard, my fault. I had a couple of the 2.1.0 libraries in /usr/local, so it linked to those instead of 2.0.1. Cleaned it out, rebuilt against 2.0.1, and it does not segfault.

comment:5 Changed 7 years ago by Even Rouault

Resolution: duplicate
Status: newclosed

Duplicate of #5579

Note: See TracTickets for help on using tickets.