Opened 8 years ago

Closed 8 years ago

#5565 closed enhancement (duplicate)

Support ESRI WKT in .prj files

Reported by: wolf Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SRS Version: unspecified
Severity: normal Keywords: WKT, prj, shapefile
Cc:

Description

It seems that the shapefile driver only supports the OGC WKT .prj files, and fails to detect projection information when faced with a .prj file created by ESRI software, which doesn't contain the PROJ parameter and uses different names for some of the projections.

Example .prj file here which doesn't work (this is for EPSG:3857) http://pastebin.com/azijqu0n

Change History (1)

comment:1 by Even Rouault, 8 years ago

Resolution: duplicate
Status: newclosed

ESRI WKT is assumed when parsing .prj files of shapefiles, but EPSG:3857 morphing from ESRI is a known issue. Closing as a duplicate of #3962

Note: See TracTickets for help on using tickets.