Opened 8 years ago

Closed 8 years ago

#5443 closed defect (invalid)

undefined reference using libkml1.3.0 with gdal_trunk

Reported by: rashadkm Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SF Version: svn-trunk
Severity: blocker Keywords: ogr, likml
Cc:

Description

gdal supports libkml driver only for libkml 1.3.0 which by the way is not released or tagged. The trunk version was considered as libkml 1.3.0. gdal.1.10.1 is not able to detect libkml1.3.0. But gdal-trunk detects this and compiles propoerly.

GDAL 1.12dev, released 2014/04/16
./ogr2ogr --formats
Supported Formats:
  -> "ESRI Shapefile" (read/write)
  -> "MapInfo File" (read/write)
  -> "UK .NTF" (readonly)
  -> "SDTS" (readonly)
  -> "TIGER" (read/write)
  -> "S57" (read/write)
  -> "DGN" (read/write)
  -> "VRT" (readonly)
  -> "REC" (readonly)
  -> "Memory" (read/write)
  -> "BNA" (read/write)
  -> "CSV" (read/write)
  -> "GML" (read/write)
  -> "GPX" (read/write)
  -> "LIBKML" (read/write)
  -> "KML" (read/write)
  -> "GeoJSON" (read/write)
  -> "GMT" (read/write)
  -> "GPKG" (read/write)
  -> "SQLite" (read/write)
  -> "WAsP" (read/write)
  -> "PCIDSK" (read/write)
  -> "OpenFileGDB" (readonly)
  -> "XPlane" (readonly)
  -> "AVCBin" (readonly)
  -> "AVCE00" (readonly)
  -> "DXF" (read/write)
  -> "Geoconcept" (read/write)
  -> "GeoRSS" (read/write)
  -> "GPSTrackMaker" (read/write)
  -> "VFK" (readonly)
  -> "PGDump" (read/write)
  -> "OSM" (readonly)
  -> "GPSBabel" (read/write)
  -> "SUA" (readonly)
  -> "OpenAir" (readonly)
  -> "PDS" (readonly)
  -> "WFS" (readonly)
  -> "HTF" (readonly)
  -> "AeronavFAA" (readonly)
  -> "EDIGEO" (readonly)
  -> "GFT" (read/write)
  -> "GME" (read/write)
  -> "SVG" (readonly)
  -> "CouchDB" (read/write)
  -> "Idrisi" (readonly)
  -> "ARCGEN" (readonly)
  -> "SEGUKOOA" (readonly)
  -> "SEGY" (readonly)
  -> "ODS" (read/write)
  -> "XLSX" (read/write)
  -> "ElasticSearch" (read/write)
  -> "PDF" (read/write)
  -> "CartoDB" (readonly)
  -> "SXF" (readonly)

Everything is fine upto here: but getting link errors:

/home/otbtesting/OTB/bin/gdal-trunk/lib/libgdal.so: undefined reference to `kmldom::Container::DeleteFeatureAt?(unsigned long)' clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: * [bin/otbTestDriver] Error 1

Attachments (3)

gdal_weekly_err.log (91.2 KB) - added by rashadkm 8 years ago.
link errors
gdal_weekly_out.log (243.1 KB) - added by rashadkm 8 years ago.
compile output
gdal_weekly_out.2.log (243.1 KB) - added by rashadkm 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by rashadkm

Attachment: gdal_weekly_err.log added

link errors

Changed 8 years ago by rashadkm

Attachment: gdal_weekly_out.log added

compile output

Changed 8 years ago by rashadkm

Attachment: gdal_weekly_out.2.log added

comment:1 Changed 8 years ago by Even Rouault

I guess it must be an issue with an unclean build. libkml detection hasn't changed between trunk and 1.10. Try with a clean tree.

comment:2 Changed 8 years ago by rashadkm

I tried from a clean build but still I have got the same error. You could see the dashboard build here - http://dash.orfeo-toolbox.org/viewBuildError.php?buildid=145378

It doesnt give any issues with libkml1.2.0. But gdal trunk wont be having libkml driver with that version.

comment:3 Changed 8 years ago by Even Rouault

Sorry, I'm confused by your report. No version of the libkml driver has ever worked with libkml 1.2.0 as far as I know, so no point in trying to build against it... Which combinations of GDAL versions and libkml version are you trying ? All recent versions of GDAL should be built against the latest svn (or git now) version of libkml

comment:4 Changed 8 years ago by rashadkm

Ok. Sorry for the confusion. Svn up

Updated to revision 27240.

libkml svn info - URL: http://libkml.googlecode.com/svn/trunk Relative URL: /trunk Repository Root: http://libkml.googlecode.com/svn Repository UUID: bf31a577-0547-0410-9073-f3f9481b7c33 Revision: 864 Node Kind: directory Schedule: normal Last Changed Author: kml.mashbridge Last Changed Rev: 864 Last Changed Date: 2011-06-29 02:34:25 +0200 (mer., 29 juin 2011)

When tried with libkml1.2.0, during configure it detects the headers but didnt built the libkml driver. This happens with trunk and 1.10.1 releases. From what you said I think this is normal as libkml1.3.0 is the only supported version.

I will try a fresh checkout of source of both gdal and libkml now and check on this error again.

comment:5 Changed 8 years ago by rashadkm

Resolution: invalid
Status: newclosed

This issue should be closed as the build is sucessful now. The issue was there was two libkml version 1.2 and 1.3.0 and gdal uses 1.3.0 and other library was using 1.20 which resulted in undefined references

Note: See TracTickets for help on using tickets.