Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#5387 closed defect (fixed)

GDALWARP INIT_DEST called on each file

Reported by: pica Owned by: warmerdam
Priority: normal Milestone: 1.11.2
Component: Utilities Version: svn-trunk
Severity: normal Keywords: GDALWARP INIT_DEST
Cc:

Description

The warp option INIT_DEST of gdalwarp is executed for each file entered. If just one file is called, everything is right, but if you enter *.tif as input in order to assembly a folder, just the last tiff called by the function will be in the output file because all other warped tiff will be erased with the parameters of init_dest

gdalwarp -of GTIFF -WO INIT_DEST=255,255,255,0 *.tif output.tiff

In order to solve this, using a vrt of a folder of tif and sending this vrt to gdalwarp works fine because the initialisation of the final tiff is launched just one time before warping the vrt

Change History (3)

comment:1 Changed 7 years ago by Even Rouault

Milestone: 1.10.21.11.2
Resolution: fixed
Status: newclosed

trunk r28183, branches/1.11 r28184 "gdalwarp: only apply INIT_DEST when processing the first input dataset (#5387)"

comment:2 Changed 7 years ago by Even Rouault

trunk r28185, branches/1.11 r28186 "Fix regression caused by previous commit (#5387)"

comment:3 Changed 6 years ago by Even Rouault

Arg, this fix caused a regression now fixed by :

trunk r28832, branches/1.11 r28834 "gdalwarp: fix trunk/1.11.2 regression when invoking several times gdalwarp with several input files on the same target file, and when the input files have a nodata setting: only the last input file was warped onto the target dataset (#5909)"

Note: See TracTickets for help on using tickets.