Opened 8 years ago

Closed 7 years ago

#5261 closed defect (worksforme)

the ogr2ogr utility crashed while translating shp to kml or gml

Reported by: liminlu0314 Owned by: warmerdam
Priority: normal Milestone: 1.10.2
Component: Utilities Version: 1.10.0
Severity: normal Keywords: ogr2ogr
Cc:

Description (last modified by liminlu0314)

the ogr2ogr utility crashed while translating shp to kml or gml

test file in attach

Attachments (1)

beijing_shp.zip (31.2 KB) - added by liminlu0314 8 years ago.
test file

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by liminlu0314

Attachment: beijing_shp.zip added

test file

comment:1 Changed 8 years ago by liminlu0314

Description: modified (diff)
Summary: the ogr2ogr utilitie crashed while translating shp to kml or gmlthe ogr2ogr utility crashed while translating shp to kml or gml

comment:2 Changed 8 years ago by Even Rouault

I cannot reproduce any crash with the provided test file with ogr2ogr with 1.10.0 or 1.10.1, with Linux. What is your operating system and where did you get the GDAL/OGR binaries ?

comment:3 in reply to:  2 Changed 8 years ago by liminlu0314

Replying to rouault:

I cannot reproduce any crash with the provided test file with ogr2ogr with 1.10.0 or 1.10.1, with Linux. What is your operating system and where did you get the GDAL/OGR binaries ?

OS:Window7 64bit GDAL:QGIS 2.0 OSGeo4W

My own compilation GDAL also can appear this crash.

ogr2ogr --version GDAL 1.10.0, released 2013/04/24

comment:4 Changed 8 years ago by Even Rouault

Did you try with the builds available at http://www.gisinternals.com/sdk/ ?

comment:5 Changed 7 years ago by Jukka Rahkonen

Resolution: worksforme
Status: newclosed

Even: "Did you try with the builds available at http://www.gisinternals.com/sdk/ ? "

I had a try, works for me. Closing.

Note: See TracTickets for help on using tickets.