Opened 11 years ago

Closed 11 years ago

#5058 closed defect (fixed)

Crash in gdalwarp using lanczos filter

Reported by: stigrk Owned by: warmerdam
Priority: normal Milestone: 1.10.0
Component: default Version: unspecified
Severity: normal Keywords: gdalwarp lanczos


I have a crash in gdalwarp when resampling an image using the Lanczos filter.

This happens on Windows x64 built with MSVC2010 using the 1.10RC3 version.

I have not tried with gdal built for other platforms.

The input file I am using can be downloaded here (96MB):

The same command works with the 1.9 version of gdal but gives some resampling artifacts, which is why I wanted to try the latest development version.

The command I try to run: gdalwarp.exe -s_srs EPSG:4326 -t_srs EPSG:3785 -te 12675093.778361067 3463514.625657905 12679985.748171318 3468406.595468156 -ts 256 256 -r lanczos -overwrite merged.tif test.jpg

It does not crash if I use the CubicSpline filter.

Change History (5)

comment:1 by Even Rouault, 11 years ago

Hum, I downloaded your file and tried to reproduce under Linux 64bit and Windows 32bit, but both ran fine. On Linux 64bit, I tried with Valgrind, a run-time memory bad usage detector, and it didn't raise any warning or error. Did you build your 1.10RC3 version yourself ? If so, could you use instead the package built at ?

comment:2 by Even Rouault, 11 years ago

I've just tested with the\gdal-110dev-1600-x64-core.msi in a Windows 7 64bit VM and it worked. So I strongly suspect something is wrong in the way you have built GDAL.

comment:3 by stigrk, 11 years ago

Weird, that is the same version I tried with (the zipped version), perhaps there is some other dependency or some dll conflict happening?

I am at home now, I will try on my home computer now. It have never seens gdal before and is actually a pretty clean install.

Will report back.

comment:4 by stigrk, 11 years ago

I have now tried at home and it does work using the msi file. However all is not good.

The file I posted is actually a somewhat scaled down version of the original file that is about 300 megabytes, I scaled it down somewhat to reduce the download size. That file still consistently crashed my work computer.

If I tried with the full size file and it crashes on my home computer. Same behaviour, if I switch to any other filter it works.

It seems to me there might be a memory/file size issue with the lanczos filter.

The full size file is here:

Could I please bother you to try the big file with your computer?

comment:5 by Even Rouault, 11 years ago

Resolution: fixed
Status: newclosed

Reproduced and fixed in trunk (r25934) and branches/1.10 (r25935)

Note: See TracTickets for help on using tickets.