Opened 10 years ago

Closed 4 years ago

#4649 closed defect (wontfix)

PostGIS Raster driver: overviews found as non regular

Reported by: mauriciodev Owned by: jorgearevalo
Priority: normal Milestone: closed_because_of_github_migration
Component: GDAL_Raster Version: 1.9.0
Severity: major Keywords:
Cc:

Description

It seems that the driver is not recognizing the overviews created by the default loader as regular overviews. I've performed a few tests using the python console: In [5]: band=f.GetRasterBand(1) In [6]: band.GetOverviewCount() Out[6]: 0 In [8]: band.HasArbitraryOverviews() Out[8]: True

On this table I created the 2,4,8,16 overviews altogether. I've checked the raster_overviews view in postgresql and there are 4 lines, correctly described as the overviews. I've also been able to read the overview tables in the QGIS plugin by choosing them instead of the base raster. I made my tests using ubuntu 11.10, gdal 1.9, postgis 2.0, qgis 1.7.

Since this is disables the overview reading, the driver's performance is greatly decreased.

Change History (6)

comment:1 by jorgearevalo, 10 years ago

Owner: changed from warmerdam to jorgearevalo
Status: newassigned

comment:2 by jorgearevalo, 10 years ago

Component: defaultGDAL_Raster
Milestone: 1.9.1
Version: unspecified1.9.0

comment:3 by jorgearevalo, 10 years ago

I think the problem is solved after r24867. If you can confirm it's working, I close the ticket.

comment:4 by jorgearevalo, 9 years ago

Milestone: 1.10.1

comment:5 by Even Rouault, 7 years ago

Milestone: 1.10.1

Removing obsolete milestone

comment:6 by Even Rouault, 4 years ago

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: assignedclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.