Opened 9 years ago

Closed 9 years ago

#4527 closed defect (fixed)

[PATCH] KML Superoverlay only generates one zoom level

Reported by: ryanl Owned by: Robert Coup
Priority: normal Milestone: 1.9.1
Component: GDAL_Raster Version: 1.9.0
Severity: normal Keywords: KML Superoverlay kmlsuperoverlay
Cc:

Description

Currently the KML Superoverlay driver will only generate the most detailed zoom level. If the resulting kml is opened in Google Earth then only a single tile (0/0/0.kml) is ever displayed.

This was introduced in [23384] by resetting the maxzoom variable to 0 before it is used.

This patch removes the line setting maxzoom to zero.

Attachments (2)

maxzoom_fix.diff (491 bytes) - added by ryanl 9 years ago.
Patch for r24007
maxzoom_test.diff (958 bytes) - added by ryanl 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by ryanl

Attachment: maxzoom_fix.diff added

Patch for r24007

comment:1 Changed 9 years ago by Even Rouault

Milestone: 1.9.1
Version: svn-trunk1.9.0

Doh, I don't understand why I committed that bogus line. There's a regression test in autotest/gdrivers/kmlsuperoverlay.py , but it didn't catch the regression because it uses a too small raster that just needs the 0 level ... Would be great to extend it a bit more with a less trivial case. So letting this bug open.

Fixed in trunk (r24009) and branches/1.9 (r24010)

Changed 9 years ago by ryanl

Attachment: maxzoom_test.diff added

comment:2 Changed 9 years ago by ryanl

I have attached a patch that will use a raster that is 512x512px which will result in a superoverlay with a 0 and a 1 level.

comment:3 Changed 9 years ago by Robert Coup

Resolution: fixed
Status: newclosed

Test committed in r24013 (trunk) and r24014 (branches/1.9)

Note: See TracTickets for help on using tickets.