Opened 8 years ago

Closed 8 years ago

#4342 closed defect (invalid)

Rotated raster images are not recognized

Reported by: mortcanty Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: 1.8.1
Severity: normal Keywords:
Cc:

Description

Using the Python GDAL package to read path-oriented satellite raster images in ENVI, GeoTIFF, ERDAS Imagine, PCI Geomatics and other formats I find that the rotation is always ignored and the images are incorrectly interpreted as being oriented north-up.

Change History (1)

comment:1 Changed 8 years ago by Even Rouault

Resolution: invalid
Status: newclosed

My understanding of your report (but it is not very sufficiently detailed so that I can be sure of my understanding) is that it is not a bug but the intended behaviour. In case of rotate images, the rotation will be reported in the geotransform matrix, but the image you get with ReadRaster?() will not have the rotation. You must use the warping algorithm to apply the rotation.

Please reopen if I've not understood what you mean. In which case attaching the output of gdalinfo on such a dataset, and a small snippet of your code, should help better understanding what you mean.

Note: See TracTickets for help on using tickets.