Opened 11 years ago

Closed 11 years ago

#4323 closed defect (fixed)

autotest/warp/warp.py: TEST warp_27 fails

Reported by: peifer Owned by: warmerdam
Priority: normal Milestone:
Component: Autotest Version: svn-trunk
Severity: normal Keywords:
Cc:

Description

The test checks if its result is the same as gdalwarp -rb -t_srs EPSG:4326 ../gcore/data/byte.tif tmp/warp_27.tif. This is true AFAICT, as the Checksum() is in both cases 4586. However, the test fails as it checks for a checksum value of 4583:

     if cs != 4583:
        return 'fail'

(I was testing on 64bit Linux.)

Change History (3)

comment:1 by Even Rouault, 11 years ago

Which compiler version do you use ? GDAL compiled with -O2 or not ?

comment:2 by peifer, 11 years ago

The configure script tells me:

GDAL is now configured for x86_64-unknown-linux-gnu

  C compiler:                gcc -g -O2
  C++ compiler:              g++ -g -O2
...

$ g++ --version | head -1
g++ (Debian 4.6.1-13) 4.6.1

comment:3 by Even Rouault, 11 years ago

Resolution: fixed
Status: newclosed

I've tried to reproduce with a self-compiled gcc 4.6.1, but it worked for me, so I've changed the test so as to compare effectively with the result of 'gdalwarp -rb -t_srs EPSG:4326 ../gcore/data/byte.tif tmp/warp_27_ref.tif'. Hopefully the difference you see is some subtle rounding difference without much impact, but it is still weird I can't reproduce

r23305 /trunk/autotest/warp/warp.py: Make warp_27 more robust (#4323)

Note: See TracTickets for help on using tickets.