Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4111 closed defect (invalid)

ogr2ogr segmentation fault on PostgreSQL output

Reported by: gfleming Owned by: warmerdam
Priority: normal Milestone:
Component: Utilities Version: 1.8.0
Severity: normal Keywords:
Cc: aboudreault

Description

running ogr2ogr to convert a shapefile to PostGIS gives a segmentation fault with no stack trace.

I have tried mapinfo and gml output an they work fine.

It does this on two machines I have tried.

The exact same command was used routinely in production for over a year on 1.7 with no problem. No matter what options I try or how simple I make the command it gives a seg fault every time now.

Ubuntu 11.04 amd64

PostGIS 1.5 on PostgreSQL 8.4

ogrinfo --version GDAL 1.8.0, released 2011/01/12

Attachments (1)

sc_a_parks.zip (27.7 KB) - added by gfleming 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Even Rouault

Could you attach a shapefile that triggers this issue and give the exact command line you use ?

Could you also run it under gdb and display the stack trace when it crashes ? And/or running under Valgrind ?

Changed 11 years ago by gfleming

Attachment: sc_a_parks.zip added

comment:2 Changed 11 years ago by gfleming

This GDB was configured as "x86_64-linux-gnu". For bug reporting instructions, please see: <http://www.gnu.org/software/gdb/bugs/>... Reading symbols from /usr/bin/ogr2ogr...(no debugging symbols found)...done. (gdb) run -f "PostgreSQL" PG:"host='localhost' user='gavin' dbname='t4a'" sc_a_parks.shp Starting program: /usr/bin/ogr2ogr -f "PostgreSQL" PG:"host='localhost' user='gavin' dbname='t4a'" sc_a_parks.shp [Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault. 0x00007ffff5f194a8 in adler32 () from /usr/lib/libepsilon.so.0

comment:3 Changed 11 years ago by Even Rouault

Type "bt" (for backtrace) when gdb catches the SIGSEGV and paste the output, so we can have a usefull stacktrace :-) Where did you get your GDAL binary : did you compile it by yourself or got it from some repository ?

comment:4 Changed 11 years ago by gfleming

It's from the UbuntuGIS-unstable repository, here's the backtrace:

(gdb) bt #0 0x00007ffff5f194a8 in adler32 () from /usr/lib/libepsilon.so.0 #1 0x00007ffff19a9621 in ?? () from /lib/x86_64-linux-gnu/libz.so.1 #2 0x00007ffff19a9938 in ?? () from /lib/x86_64-linux-gnu/libz.so.1 #3 0x00007ffff19aab4a in deflate () from /lib/x86_64-linux-gnu/libz.so.1 #4 0x00007fffefdd31f3 in ?? () from /lib/libcrypto.so.0.9.8 #5 0x00007fffefdd26e0 in COMP_compress_block () from /lib/libcrypto.so.0.9.8 #6 0x00007ffff0071d9e in ssl3_do_compress () from /lib/libssl.so.0.9.8 #7 0x00007ffff0072057 in ?? () from /lib/libssl.so.0.9.8 #8 0x00007ffff0072389 in ssl3_write_bytes () from /lib/libssl.so.0.9.8 #9 0x00007ffff00737b2 in ssl3_do_write () from /lib/libssl.so.0.9.8 #10 0x00007ffff006ede4 in ssl3_connect () from /lib/libssl.so.0.9.8 #11 0x00007ffff383ef70 in ?? () from /usr/lib/libpq.so.5 #12 0x00007ffff382fd7e in PQconnectPoll () from /usr/lib/libpq.so.5 #13 0x00007ffff3830bae in ?? () from /usr/lib/libpq.so.5 #14 0x00007ffff383222f in PQconnectdb () from /usr/lib/libpq.so.5 #15 0x00007ffff7866cf6 in ?? () from /usr/lib/libgdal1.8.0.so.1 #16 0x00007ffff786a01b in ?? () from /usr/lib/libgdal1.8.0.so.1 #17 0x0000000000405615 in ?? () #18 0x00007ffff65abeff in libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6 #19 0x00000000004033b9 in ?? () #20 0x00007fffffffe168 in ?? () #21 0x000000000000001c in ?? () #22 0x0000000000000005 in ?? () #23 0x00007fffffffe476 in ?? () #24 0x00007fffffffe487 in ?? () #25 0x00007fffffffe48a in ?? () #26 0x00007fffffffe495 in ?? () #27 0x00007fffffffe4d9 in ?? () #28 0x0000000000000000 in ?? ()

comment:5 Changed 11 years ago by Even Rouault

Resolution: invalid
Status: newclosed

OK, now it reminds me of the problem I got a few months/years ago. You should report it to UbuntuGIS so that they can read http://trac.osgeo.org/gdal/wiki/Epsilon and apply the patch in it to libepsilon

Not a GDAL bug in fact.

comment:6 Changed 11 years ago by warmerdam

Cc: aboudreault added

comment:7 Changed 11 years ago by aboudreault

Since the epsilon package is not a part of UbuntuGIS, I'm going to disable that support. Perhaps, the epsilon package will be fixed in the next release.

Note: See TracTickets for help on using tickets.