Opened 9 years ago

Closed 5 years ago

#3854 closed defect (invalid)

Unable to delete external overviews in JPEG2000 compressed NITF

Reported by: rprinceley Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: svn-trunk
Severity: normal Keywords: nitf jp2kak
Cc:

Description

In JPEG2000 compressed NITFs with external overviews, the .ovr is opened by the underlying JPEG2000 (JP2KAKDataset) driver. Calls to NITFDataset::IBuildOverviews to delete overviews fail because .ovr is kept open by JP2KAKDataset (can't delete once .ovr is loaded).

Change History (3)

comment:1 Changed 9 years ago by warmerdam

Keywords: nitf jp2kak added
Status: newassigned

comment:2 Changed 9 years ago by warmerdam

Robin,

I have been unable to reproduce this problem.

I tried a variety of things on the test file http://home.gdal.org/tmp/bug3854.ntf - a sample jpeg2000 in nitf file from the NITF folks. Tests included:

  gdaladdo bug3854.ntf 2 4 8
  gdaladdo -clean bug3854.ntf

I also tried adding the overviews and then cleaning them without closing and reopening the dataset, but I found that GetOverview? failed. It seems that overviews are not available in the same session they are built for the esoteric case of bulding them against an NITF based on jpeg2000 data. I'm not sure if you have encountered that.

(BTW, I tried with trunk and 1.8.x since trunk has been changed to use /vsisubfile instead of the J2K_SUBFIKLE mechanism.)

comment:3 Changed 5 years ago by Jukka Rahkonen

Resolution: invalid
Status: assignedclosed

Even could not reproduce, no feedback received. Closing.

Note: See TracTickets for help on using tickets.