Opened 10 years ago

Closed 5 years ago

#3691 closed defect (invalid)

GDAL doesn't create correct image from WCS indexed raster

Reported by: yjacolin Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description (last modified by yjacolin)

How to see this bug:

  1. create a WCS service (with MapServer? for instance) with an indexed raster layer. Set up an imagemode to PC256 and in METADATA object of the layer:
"wcs_bandcount" "1"
  1. you need an indexed raster file, you can create it with rgb2pct.py script from a RGBA raster file
  2. retrieve image directly with the GetCoverage? request (image #1)
  3. retrieve image with gdal (image #2)

image #1 and #2 are different (b&w for #2, color for #1)

Here is an xml code to put in a file to use with gdal and a GetCoverage? url to see both image.

<WCS_GDAL>
  <ServiceURL>http://ifremer-maintenancesextant-demo.dmz.lsn.camptocamp.com/cgi-bin/bug?</ServiceURL>
  <CoverageName>test</CoverageName>
</WCS_GDAL>

http://ifremer-maintenancesextant-demo.dmz.lsn.camptocamp.com/cgi-bin/bug?SERVICE=WCS&COVERAGE=test&TRANSPARENT=true&VERSION=1.1.1&FORMAT=geotiff&REQUEST=GetCoverage&STYLES=&EXCEPTIONS=application/vnd.ogc.se_inimage&CRS=EPSG:27561&BBOX=82999.9,107400.1,83999.9,109000.1&WIDTH=800&HEIGHT=570

server could be closed one day, even if I try to keep it on, so don't hesitate to contact me if this occurs and you need it to work on this ticket.

Thanks.

Y. PS : edit to change url to the public url

Change History (4)

comment:1 Changed 10 years ago by yjacolin

Hello,

Sorry this server is not public yet. We are working on it and let you know the correct url.

Thanks,

Y.

comment:2 Changed 9 years ago by yjacolin

Description: modified (diff)

Hello,

comment:3 Changed 5 years ago by Jukka Rahkonen

yjacolin, could you repeat your test with current GDAL and Mapserver versions? A small zip with some sample data and complete mapfile for reproducing the issue would be a nice surprise.

comment:4 Changed 5 years ago by Jukka Rahkonen

Resolution: invalid
Status: newclosed

Comparing image 1 (the original file on Mapserver) with image 2 (image stored with GDAL from the WCS service) in not a test. You should have saved the GeoTIFF from the service directly on disk with wget or curl into image 3 and compare 2 vs. 3.

I believe that Mapserver really sent the GeoTIFF without palette and therefore the result on the client side was gray scale. I and yjacolin have no means to prove that because the server has disappeared a long time ago. Make a new test with Mapserver 2.0 and GDAL 2.0 and create a new ticket if necessary.

Note: See TracTickets for help on using tickets.