Opened 11 years ago

Closed 11 years ago

#3670 closed defect (duplicate)

Solaris 10 compile fail with version 1.7.2

Reported by: guest Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 1.7.2
Severity: major Keywords:
Cc:

Description

Hi,

On Solaris 10 Sparc, GDAL make fails with:

bash-3.00# gmake (cd port; gmake) gmake[1]: Entering directory `/home1/Solaris10/Mapserver/gdal-1.7.2/port' /bin/sh /home1/Solaris10/Mapserver/gdal-1.7.2/libtool --mode=compile --tag=CXX g++ -g -O2 -Wall -DOGR_ENABLED -I/home1/Solaris10/Mapserver/gdal-1.7.2/port -I/usr/local/include -DHAVE_CURL -DHAVE_LIBZ -c -o cpl_conv.lo cpl_conv.cpp /home1/Solaris10/Mapserver/gdal-1.7.2/libtool: syntax error at line 659: `func_arith_result=$' unexpected gmake[1]: * [cpl_conv.lo] Error 2 gmake[1]: Leaving directory `/home1/Solaris10/Mapserver/gdal-1.7.2/port' gmake: * [port-target] Error 2

Version 1.7.1 compiles just fine.

System: uname -a SunOS rgsc3 5.10 Generic_141444-09 sun4u sparc SUNW,Sun-Fire-V240

Change History (3)

comment:1 Changed 11 years ago by Even Rouault

Looks like a libtool related issue. There was indeed an upgrade of configure/libtool/etc between GDAL 1.7.1 and 1.7.2.

./configure --without-libtool might help you to workaround. Myself I can't do more to help

comment:2 Changed 11 years ago by mattnott

I had the same problem. The issue is that libtool is being run as '/bin/sh libtool'. On solaris sh isn't bash but a real bourne shell and the libtool has a bash'ism in it. My fix was to edit the file 'GDALmake.opt' and change the line (about line 8) from being

LIBTOOL = $(SHELL) $(top_builddir)/libtool

to be

LIBTOOL = $(top_builddir)/libtool

(As the first line of libtool is /bin/bash (well it was on my solaris box - best if you double check as I look on my Linux box and it says /bin/sh! - they joys of auto*)

Hope this helps - let me know if you need more information/testing.

comment:3 Changed 11 years ago by Even Rouault

Resolution: duplicate
Status: newclosed

Duplicate of #3611 actually

Note: See TracTickets for help on using tickets.