Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3362 closed defect (fixed)

gcs.override.csv has wrong datum shift for Belge 1972

Reported by: mikrit Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SRS Version: unspecified
Severity: normal Keywords: datum shift
Cc:

Description

The file

http://svn.osgeo.org/metacrs/geotiff/trunk/libgeotiff/csv/gcs.override.csv

contains the lines

# From Jan: http://bugzilla.remotesensing.org/show_bug.cgi?id=1336 # 4313,Belge 1972, [- stuff deleted -] ,9606,106.868628,-52.297783,103.723893,-0.336570,0.456955,-1.842183,1.0000012747

However, this is wrong. The error can be 190 meters (at least). The correct line should end with

... ,9607,-106.8686,52.2978,-103.7239,-0.3366,0.457,-1.8422,-1.2747

For more details, see http://trac.osgeo.org/proj/ticket/65 and http://lists.maptools.org/pipermail/proj/2010-January/thread.html

Best regards,

Change History (7)

comment:1 Changed 10 years ago by warmerdam

Component: defaultOGR_SRS
Keywords: datum shift added
Status: newassigned

This is really a libgeotiff issue. I have committed http://trac.osgeo.org/geotiff/changeset/1801 with the suggested change.

I would like to have a test point in this GCS and it's corresponding WGS84 point that I could add to a test suite. Could you please supply one?

comment:2 Changed 10 years ago by mikrit

Yes, I used a Belgian converter tool, downloaded via http://www.ngi.be/FR/FR4-4.shtm , to obtain the following test point in west Belgium:

WGS84: 2°30' E, 51° N

Belge 1972: 2°30'04.37266" E, 50°59'58.09273" N

Actually, I am not quite sure whether I made the tool to use the 7-parameter shift or some grid shift file. But the standard deviation between the two possibilities is supposed to be only 0.2 meters.

(And strictly speaking, the 2°30' E, 51° N coordinates are really ETRS89 instead of WGS84. But the differences are mainly caused by the continental drift since 1989.)

comment:3 Changed 10 years ago by warmerdam

Hmm, I tried this test point with what I now believe to be the correct parameters and I did not get the expected values:

cs2cs +proj=longlat +ellps=WGS84 +datum=WGS84 +to \
   +proj=longlat +ellps=intl +towgs84=-106.869,52.2978,-103.724,0.3366,-0.457,1.8422,1.2747 \
   +no_defs
-2.5 51
2d30'3.846"W    51d0'1.824"N -54.814

Any thoughts on why this might not be giving the expected results?

comment:4 Changed 10 years ago by mikrit

You've got the parameters right - as far as I can see - but you prepended a minus sign to the test point longitude. I guess it comes automatic when you live on the western hemisphere.

By the way, you can find test points for European datums on http://www.crs-geo.eu , although the site it a bit awkward to navigate. Go to "CRS Description", then go to "national CRS", then go to "Belgium", then on row BE_BD72 / LAMB72, click the link in the column "Descr. of Transf." (which gives a somewhat older datum shift, by the way), then scroll down to the bottom and go to "Verification Data".

comment:5 Changed 10 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

Hmm, with the correct direction for East, I get:

2.5 51
2d29'55.627"E   51d0'1.909"N -57.688

Still not very close to what you quote as correct results, and going in the wrong direction.

Using the first test point from the verification data on the site you mention:

        BE_BD72  (DMS)                      ETRS89 (DMS)
------------------------------------------------------------------
    Lat           Lon (E is +)            Lat         Lon (E is +)
------------------------------------------------------------------
51  6 40.6800     3  3 28.4400       51  6 38.77      3  3 32.87
49 41 38.0400     5 38 29.7600       49 41 35.94      5 38 34.38

I get:

input: 3d3'32.87 51d6'38.77
output: 3d3'28.434"E    51d6'40.678"N -57.899

which is accurate to a small fraction of a second (treating WGS84==ETRS89). So I suppose the result is ok.

comment:6 Changed 10 years ago by mikrit

Oops, I'm sorry. I confused WGS84 and BD72 when I reported my test point above. It is the point 2°30' E, 51° N that is in BD72, and the point 2°30'04.37266" E, 50°59'58.09273" N is in WGS84. ( See http://lists.maptools.org/pipermail/proj/2010-January/005030.html )

comment:7 Changed 10 years ago by warmerdam

OK, I'm gettinggood agreement now.

2.5 51
2d30'4.373"E    50d59'58.091"N 57.690
Note: See TracTickets for help on using tickets.