Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#3351 closed defect (duplicate)

ogrinfo and python bindings segfault on certain shapefile

Reported by: sonicx Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SF Version: unspecified
Severity: normal Keywords: segfault, shape
Cc:

Description (last modified by warmerdam)

I have a shapefile which makes ogrinfo segfault, python segfaults with the following errors upon trying use ogr module with it:

*** glibc detected *** python: free(): invalid next size (fast): 0x0000000004bc44b0 ***                     
======= Backtrace: =========                                                                                
/lib/libc.so.6[0x7fa781a90d56]                                                                              
/lib/libc.so.6(cfree+0x6c)[0x7fa781a959bc]                                                                  
/usr/lib/libgdal.so.1(DBFOpenLL+0x5da)[0x7fa774f83faa]                                                      
/usr/lib/libgdal.so.1(DBFOpen+0x2f)[0x7fa774f840bf]                                                         
/usr/lib/libgdal.so.1(_ZN18OGRShapeDataSource8OpenFileEPKcii+0xb5)[0x7fa775014a95]                          
/usr/lib/libgdal.so.1(_ZN18OGRShapeDataSource4OpenEPKciii+0xdd)[0x7fa775014e7d]                             
/usr/lib/libgdal.so.1(_ZN14OGRShapeDriver4OpenEPKci+0x42)[0x7fa7750155d2]                                   
/usr/lib/libgdal.so.1(_ZN20OGRSFDriverRegistrar4OpenEPKciPP11OGRSFDriver+0xbd)[0x7fa77501380d]              
/usr/lib/python2.5/site-packages/GDAL-1.6.3-py2.5-linux-x86_64.egg/osgeo/_ogr.so(_Z4OpenPKci+0x24)[0x7fa7736b74a4]                                                                                              

That strange shape is attached.

Attachments (1)

shape.tar.bz2 (784.0 KB) - added by sonicx 10 years ago.
The error-producing shapefile.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by sonicx

Attachment: shape.tar.bz2 added

The error-producing shapefile.

comment:1 Changed 10 years ago by warmerdam

Component: defaultOGR_SF
Description: modified (diff)
Status: newassigned

I have been unable to reproduce a problem with ogr trunk. Tested on windows, and on 32bit linux (built from source) under valgrind.

What version are you using?

Things I tried included:

  valgrind ogrinfo -al hydrotop.shp > /dev/null

comment:2 in reply to:  1 Changed 10 years ago by sonicx

Replying to warmerdam:

I have been unable to reproduce a problem with ogr trunk. Tested on windows, and on 32bit linux (built from source) under valgrind.

What version are you using?

Things I tried included:

  valgrind ogrinfo -al hydrotop.shp > /dev/null

GDAL 1.6.3, released 2009/11/19 Will get fresh copy from SVN and try with that.

comment:3 Changed 10 years ago by Even Rouault

Milestone: 1.6.4
Resolution: duplicate
Status: assignedclosed

The .DBF is corrupted. I've backported in r18663 the fix done for #3093.

comment:4 in reply to:  3 Changed 10 years ago by sonicx

Replying to rouault:

The .DBF is corrupted. I've backported in r18663 the fix done for #3093.

I downloaded sources from SVN and it works like a charm!

comment:5 Changed 7 years ago by Even Rouault

Milestone: 1.6.4

Milestone 1.6.4 deleted

Note: See TracTickets for help on using tickets.