Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#2951 closed defect (fixed)

[Regression] DTED driver cannot read any more files with VOL or HDR

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone:
Component: GDAL_Raster Version: 1.5.0
Severity: normal Keywords:
Cc:

Description

This capacity was lost in r11405 for GDAL 1.5.0. For example, for http://download.osgeo.org/gdal/data/dted/l5102.dhm. The strstr to detect the UHL marker doesn't work because of NUL bytes between it and the first bytes of the file.

Change History (4)

comment:1 Changed 12 years ago by Even Rouault

Resolution: fixed
Status: newclosed

Fixed in trunk (r16797), branches/1.6 (r16798) and branches/1.5 (r16799)

comment:2 Changed 12 years ago by Even Rouault

It was w118n033.dt1 actually

comment:3 Changed 12 years ago by Even Rouault

Test added in r16800

comment:4 Changed 8 years ago by Even Rouault

Milestone: 1.5.5

Milestone 1.5.5 deleted

Note: See TracTickets for help on using tickets.