Opened 13 years ago

Closed 12 years ago

#2834 closed defect (worksforme)

EPSG:3725 / NAD83(NSRS2007) UTM Zone 18 datum isn't "Mean Sea Level"

Reported by: drf5n Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SRS Version: unspecified
Severity: normal Keywords:
Cc:

Description

When I do 'ogrinfo -al -so' on an NAD83(NSRS2007) / UTM zone 18N file it reports an odd datum:

Layer name: potomac_cellcenter Geometry: Point Feature Count: 66142 Extent: (304585.699999, 4281893.931999) - (332782.598000, 4319830.716999) Layer SRS WKT: PROJCS["NAD83(NSRS2007) / UTM zone 18N",

GEOGCS["NAD83(NSRS2007)",

DATUM["Mean_Sea_Level", <<<<<<< odd

SPHEROID["GRS_1980",6378137,298.257222101]],

PRIMEM["Greenwich",0], UNIT["Degree",0.017453292519943295]],

##################################

The EPSG database ( http://www.epsg-registry.org/ ) reports the name of the datum's base geodetic CRS as "NAD83 (National Spatial Reference System 2007)". Maybe the "Mean_Sea_Level" comes from somewhere outside of OGR, but "Mean Sea Level" isn't well defined, and probably isn't correct.

I created this file using "ogr2ogr -s_srs EPSG:3725 -t_srs EPSG:3725 UTM18N/potomac_cell_depth incoming/potomac_cell_depth.shp"

Change History (1)

comment:1 Changed 12 years ago by warmerdam

Component: defaultOGR_SRS
Resolution: worksforme
Status: newclosed

I'm not sure what sort of dataset was being examined in this situation, but testepsg reports this now for EPSG:3725, which does not include the mean sea level. So I'm hopeful the issue is now corrected. Please reopen if the problem persists and provide additional data on how to reproduce it.

WKT[EPSG:3725] =
PROJCS["NAD83(NSRS2007) / UTM zone 18N",
    GEOGCS["NAD83(NSRS2007)",
        DATUM["NAD83_National_Spatial_Reference_System_2007",
            SPHEROID["GRS 1980",6378137,298.257222101,
                AUTHORITY["EPSG","7019"]],
            TOWGS84[0,0,0,0,0,0,0],
            AUTHORITY["EPSG","6759"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.01745329251994328,
            AUTHORITY["EPSG","9122"]],
        AUTHORITY["EPSG","4759"]],
    UNIT["metre",1,
        AUTHORITY["EPSG","9001"]],
    PROJECTION["Transverse_Mercator"],
    PARAMETER["latitude_of_origin",0],
    PARAMETER["central_meridian",-75],
    PARAMETER["scale_factor",0.9996],
    PARAMETER["false_easting",500000],
    PARAMETER["false_northing",0],
    AUTHORITY["EPSG","3725"],
    AXIS["Easting",EAST],
    AXIS["Northing",NORTH]]

BTW, ogrinfo on a shapefile produced by ogr2ogr -a_srs EPSG:3725 gives:

PROJCS["NAD83_NSRS2007_UTM_zone_18N",
    GEOGCS["GCS_NAD83(NSRS2007)",
        DATUM["Hungarian_Datum_1909",
            SPHEROID["GRS_1980",6378137,298.257222101]],
        PRIMEM["Greenwich",0],
        UNIT["Degree",0.017453292519943295]],
    PROJECTION["Transverse_Mercator"],
    PARAMETER["latitude_of_origin",0],
    PARAMETER["central_meridian",-75],
    PARAMETER["scale_factor",0.9996],
    PARAMETER["false_easting",500000],
    PARAMETER["false_northing",0],
    UNIT["Meter",1]]

The transformation of the datum name is a bit odd, presumably an effect of morphToESRI().

Note: See TracTickets for help on using tickets.