Opened 13 years ago

Closed 4 years ago

#2776 closed defect (wontfix)

e00 file not working with avcbin, but ok with avc driver

Reported by: warmerdam Owned by: chaitanya
Priority: normal Milestone:
Component: OGR_SF Version: 1.6.0
Severity: normal Keywords: AVCE00
Cc: Daniel Morissette, warmerdam

Description

The OGR AVCE00 driver fails to open ftp://data.massgis.state.ma.us/pub/e00/geonames/gnm71.e00 but if avcimport is run on the file it works fine with ogrinfo.

Change History (6)

comment:1 Changed 13 years ago by warmerdam

Owner: changed from warmerdam to chaitanya

Chaitanya,

This is quite possibly a tricky bug to start with, but it's worth a try. Try to step through OGRAVCE00DataSource::Open() (gdal/ogr/ogrsf_frmts/avc/ogravce00datasource.cpp) and establish why the referenced file is not recognised and opened.

comment:2 Changed 13 years ago by warmerdam

Cc: warmerdam added

comment:3 Changed 13 years ago by chaitanya

Frank,

The AVC E00 driver is not considering some of the sections in the .e00 files as layers.

In this case the whole file gnm71.e00, which contains annotation data as points, is read but at the end all the sections are disregarded since the sections containing them are not being considered as layers. This seems to be true for a few other files from the same location http://www.mass.gov/mgis/ftpgnm.htm .

The AVCE00 driver needs to be corrected. Shall I do it? I now have a lot of insight in this.

comment:4 Changed 13 years ago by warmerdam

Yes, please try and extend the E00 side of things to match the set of layer types supported by the binary portion of the same driver.

comment:5 Changed 13 years ago by chaitanya

Status: newassigned

comment:6 Changed 4 years ago by Even Rouault

Resolution: wontfix
Status: assignedclosed

The dataset is no longer accessible. Cannot reproduce

Note: See TracTickets for help on using tickets.