Opened 11 years ago

Closed 6 months ago

#2438 closed defect (wontfix)

PCIDSK Driver writes no data value only to PAM, not inside PCI file

Reported by: omidsakhi Owned by: warmerdam
Priority: low Milestone: closed_because_of_github_migration
Component: GDAL_Raster Version: 1.5.0
Severity: normal Keywords: PCIDSK
Cc:

Description

During creation or update a raster band using PCIDSK driver, the fucntion SetNoDataValue?() simply return no error and it is supposed to set or update a new no data value but nothing happens.

Change History (4)

comment:1 Changed 11 years ago by warmerdam

Keywords: PCIDSK added
Priority: normallow

I can confirm that the PCIDSK driver does not support storing nodata values in the PCI metadata. However, it should still be written to an .aux.xml file with 1.5.0. I am setting the priority to low for this since it isn't so much a bug as a missing feature of the driver.

comment:2 Changed 11 years ago by warmerdam

Component: defaultGDAL_Raster

comment:3 Changed 5 years ago by Jukka Rahkonen

Summary: PCIDSK Geomatica Driver doesn't update no data value !!PCIDSK Driver writes no data value only to PAM, not inside PCI file

comment:4 Changed 6 months ago by Even Rouault

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: newclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub?. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.