Opened 13 years ago

Closed 12 years ago

#2432 closed task (fixed)

PAM proxy mechanism should work for overviews too

Reported by: warmerdam Owned by: warmerdam
Priority: high Milestone: 1.7.0
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: PROXY
Cc: gaopeng, antonio

Description

When GDAL_PAM_PROXY_DIR is set, it should also be used for creation and preservation of overviews (.rrd or .ovr). This appears not to be the case.

eg.

gdaladdo --config GDAL_PAM_PROXY_DIR /home/warmerda/proxy_db --config USE_RRD YES --config HFA_USE_RRD YES utm.png 2
ERROR 6: The PNG driver does not support update access to existing datasets.

GDAL: GDALOpen(utm.png) succeeds as PNG.
GDAL: GDALDriver::Create(HFA,utm.aux,512,512,1,Byte,0x7ffff3a78590)
ERROR 4: Creation of file utm.aux failed.
Overview building failed.
GDAL: GDALClose(utm.png)
GDAL: GDALDeregister_GTiff() called.

It also does not work for .ovr files.

Change History (6)

comment:1 Changed 13 years ago by antonio

Cc: antonio added

comment:2 Changed 12 years ago by warmerdam

Preliminary work on proxy/overview support has been implemented in trunk (r16706, r16704).

Still in need of further testing, and regression tests.

comment:3 Changed 12 years ago by warmerdam

Status: newassigned

comment:4 Changed 12 years ago by warmerdam

Migrated to 1.6-esri branch as part of r17187.

comment:5 Changed 12 years ago by gaopeng

Building overviews on a readonly NITF with JP2 compression doesn't fail and stop. Instead, it keeps computing overview blocks and failing to write blocks. It seems it is building overviews using a JP2KAKBand.

It also generated a large aux.xml in proxy folder.

comment:6 Changed 12 years ago by warmerdam

Milestone: 1.7.0
Resolution: fixed
Status: assignedclosed

This all seems to be working properly now in trunk and 1.6-esri.

Note: See TracTickets for help on using tickets.