Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#2311 closed enhancement (fixed)

GML support to read posList and exterior/interior available in gml 3.1 SFL0

Reported by: assefa Owned by: warmerdam
Priority: normal Milestone: 1.6.0
Component: OGR_SF Version: unspecified
Severity: normal Keywords: GML
Cc: tomkralidis

Description

Upgrade to support the posList element found in gml3.1.x and also the possiblity to read exterior and interior elements for a polygon.

I will attach a patch for this. Please review and apply if appropriate.

Attachments (2)

gml2ogrgeometry.diff (3.9 KB) - added by assefa 13 years ago.
ogr_gml_geom.diff (1.8 KB) - added by assefa 13 years ago.
autotest for gml

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by assefa

Attachment: gml2ogrgeometry.diff added

Changed 13 years ago by assefa

Attachment: ogr_gml_geom.diff added

autotest for gml

comment:1 Changed 13 years ago by tomkralidis

Cc: tomkralidis added

FYI this originates from MapServer?'s implementation of OGC Filter 1.1.0 (http://trac.osgeo.org/mapserver/ticket/2111)

comment:2 Changed 13 years ago by assefa

Is there a major reason not to apply this patch?

I am also adding in this bug a thread from the mapserver list that references this bug:

"There is a patch submitted in http://trac.osgeo.org/gdal/ticket/2311 that could help in this case. The patch was intended for the reading of gml3 profile 1.

Couple of issues I had when proposing the patch is that the support for things like gml:posList are limited. According to the specs for gml3.1/level 1 gml:posList does not have any attribute but for gml3.1, it could have attributes such as a dimension (<gml:posList srsDimension="3">. The patch assumes a 2 dimension geometry. It is also my understanding that currently the ogr gml parser strips out any attribute information from the gml file, and things like "srsDimension" are not available in gml2ogrgeometry.cpp. I think any upgrade to the reader would have to address this.

Note that using this patch and modifying it a bit to assume a 3d geometries for posList elements, I was able to read polygon/line/points coming out of the wfs server (http://frameworkwfs.usgs.gov/) and display it in Mapserver. "

comment:3 Changed 13 years ago by warmerdam

Keywords: GML added
Milestone: 1.6.0
Status: newassigned

Assefa,

I've dragged my heels on this because there is another stream of GML3 supporting work going on for the NAS format. I had been thinking I would incorporate that at some point. However, scanning the actual change you propose it seems quite harmless, if perhaps not a comprehensive implementation of GML3 support. So I'll apply it.

Thanks!

comment:4 Changed 13 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

The changes have been committed in trunk (r14758).

comment:5 Changed 13 years ago by assefa

Thanks.

comment:6 in reply to:  4 Changed 12 years ago by chaitanya

Replying to warmerdam:

The changes have been committed in trunk (r14758).

Typo. It's actually r14768

comment:7 Changed 12 years ago by Even Rouault

In r17155 (1.7.0dev) : Add support for gml3.1.1 srsDimension attribute, to deal with 3D geometries (#2311). Test added in r17156

Note: See TracTickets for help on using tickets.