Opened 15 years ago

Closed 15 years ago

#2307 closed defect (duplicate)

Cannot read tiff in gdal 1.5.1 for WinCE

Reported by: mferrero Owned by: Mateusz Łoskot
Priority: high Milestone:
Component: WinCE Port Version: 1.5.0
Severity: critical Keywords:
Cc:

Description

I was able to open tiff files on WinCE with gdal 1.4.2, but now that I ricompiled gdal 1.5.1 for WinCE, I cannot read tiff files anymore. I suspect the problem is due to the libtiff changes introduced with gdal 1.5.0.

In gdal 1.5.1 when bsearch is called within TIFFFindField the value of tif->tif_nfields is initially 0. This causes bsearch to fail as the num parameter is 0. The bsearch used on WinCE is the one provided for the WinCe port (wcelibcex library).

I also tried to change the bsearch code of wcelibcex to return NULL when num is 0. The result is that now bsearch does not fail but I still have other errors returned from libtiff later in the code. The same file opened with the same code compiled for Windows XP works correctly.

Regards, Marcello Ferrero

Change History (1)

comment:1 by mloskot, 15 years ago

Resolution: duplicate
Status: newclosed

This is duplicate of already reported issue #2133

Note: See TracTickets for help on using tickets.