Opened 14 years ago

Closed 7 years ago

Last modified 6 years ago

#2072 closed defect (fixed)

ogr_srs_validate.cpp is missing Standard Parallel 1 parameter for the LAMBERT_CONFORMAL_CONIC_1SP transformation

Reported by: mrosen Owned by: warmerdam
Priority: normal Milestone: 2.0.0
Component: OGR_SRS Version: 1.11.1
Severity: normal Keywords:
Cc:

Description

>  Frank, we encountered a failure in one of our products which we 
> isolated to a fault in GDAL.
> 
> In
> http://trac.osgeo.org/gdal/browser/trunk/gdal/ogr/ogr_srs_validate.cpp
> It still shows the parameters for the 1SP variant of the Lambert 
> Conformal Conic projection as follows:
> 
> 265 	
> 266 	    SRS_PT_LAMBERT_CONFORMAL_CONIC_1SP,
> 267 	    SRS_PP_LATITUDE_OF_ORIGIN,
> 268 	    SRS_PP_CENTRAL_MERIDIAN,
> 269 	    SRS_PP_SCALE_FACTOR,
> 270 	    SRS_PP_FALSE_EASTING,
> 271 	    SRS_PP_FALSE_NORTHING,
> 272 	    NULL,
> 273 	
> 
> I believe it is missing SRS_PP_STANDARD_PARALLEL_1.
> 
> Here is what we did to cure the problem:
> 
>   269:     SRS_PT_LAMBERT_CONFORMAL_CONIC_1SP,
>   270:     SRS_PP_STANDARD_PARALLEL_1,		/// This one is not in
> GDAL
>   271:     SRS_PP_LATITUDE_OF_ORIGIN,
>   272:     SRS_PP_CENTRAL_MERIDIAN,
>   273:     SRS_PP_SCALE_FACTOR,
>   274:     SRS_PP_FALSE_EASTING,
>   275:     SRS_PP_FALSE_NORTHING,
>   276:     NULL,
>

Change History (8)

comment:1 Changed 14 years ago by warmerdam

Component: defaultOGR_SRS
Milestone: 1.5.0
Status: newassigned

Michael,

I've reviewed the parameters used in validating LCC 1SP and they match what GDAL generates in SetLCC1SP():

    SetProjection( SRS_PT_LAMBERT_CONFORMAL_CONIC_1SP );
    SetNormProjParm( SRS_PP_LATITUDE_OF_ORIGIN, dfCenterLat );
    SetNormProjParm( SRS_PP_CENTRAL_MERIDIAN, dfCenterLong );
    SetNormProjParm( SRS_PP_SCALE_FACTOR, dfScale );
    SetNormProjParm( SRS_PP_FALSE_EASTING, dfFalseEasting );
    SetNormProjParm( SRS_PP_FALSE_NORTHING, dfFalseNorthing );

What is the source of the WKT definition with SRS_PP_STANDARD_PARALLEL_1? I've discovered that ESRI WKT uses standard_paralle_1 for 1SP forms instead of latitude_of_origin (as OGR expects).

comment:2 Changed 14 years ago by warmerdam

Frank,

Thanks for your diligence here. The offending WKT came from the following PRJ file which is distributed with ArcGIS (ArcMap?) v9.2

\Program Files\ArcGIS\Coordinate Systems\Projected Coordinate Systems\County Systems\Wisconsin CRS NAD 1983 HARN Wisconsin CRS Washburn (meters).prj

Here is it:

PROJCS["NAD_1983_HARN_WISCRS_Washburn_County_Meters",GEOGCS["GCS_North_A
merican_1983_HARN",DATUM["D_North_American_1983_HARN",SPHEROID["GRS_1980
",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174
532925199433]],PROJECTION["Lambert_Conformal_Conic"],PARAMETER["False_Ea
sting",234086.8682],PARAMETER["False_Northing",188358.6058],PARAMETER["C
entral_Meridian",-91.78333333333333],PARAMETER["Standard_Parallel_1",45.
96121983333334],PARAMETER["Scale_Factor",1.0000475376],PARAMETER["Latitu
de_Of_Origin",45.96121983333334],UNIT["Meter",1.0]]

msr

comment:3 Changed 14 years ago by warmerdam

I prepared a patch to morphToESRI() and morphFromESRI() to map standard_parallel_1 to latitude_of_origin only to realize that the provided WKT includes both! At this point I'm quite confused what to do. Deferring till post beta2.

The change you made to validate should be a reasonable action within your own code tree.

comment:4 Changed 14 years ago by warmerdam

Milestone: 1.5.01.5.1

I should really followup with ESRI to find out why they have apparently duplicatous parameters and whether they can have distinct meaning. But somehow I feel I might already have done that in the past...

comment:5 Changed 7 years ago by 45136

Milestone: 1.8.12.0
Version: unspecified1.11.1

The issue is still unresolved. See http://gis.stackexchange.com/questions/128266/qgis-error-6-no-translation-for-lambert-conformal-conic-to-proj-4-format-is-kn

A comprehenisve List of ESRI WKT definitions can be found here:

http://help.arcgis.com/en/arcims/10.0/mainhelp/mergedprojects/ArcXMLGuide/elements/pcs.htm

Changing

PROJECTION["Lambert_Conformal_Conic"]

to

PROJECTION["Lambert_Conformal_Conic_1SP"]

makes the WKT definition readable for GDAL.

comment:6 Changed 7 years ago by 45136

Summary: ogr_srs_validate.cpp is missing Standard Parallel 1 parameter for the AMBERT_CONFORMAL_CONIC_1SP transformationogr_srs_validate.cpp is missing Standard Parallel 1 parameter for the LAMBERT_CONFORMAL_CONIC_1SP transformation

comment:7 Changed 7 years ago by Even Rouault

Resolution: fixed
Status: assignedclosed

trunk r29116 "MorphFromESRI(): remove duplicated Standard_Parallel_1 (with Latitude_Of_Origin) with LCC_1SP (#2072)"

comment:8 Changed 6 years ago by Even Rouault

Milestone: 2.02.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.