Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1650 closed defect (invalid)

worldfile does not honor output projection

Reported by: condit Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords:
Cc:

Description

When gdal_translate translates an image with some metric projection (for example http://www.gdal.org/dl/data/aaigrid/095b_dem_90m.asc) with -a_srs specified, the world file is generated with the projection of the source raster, not the target.

for instance: gdal_translate.exe -ot Byte -of gif -a_srs EPSG:4326 -co WORLDFILE=YES aaigrid\095b_dem_90m.asc C:\temp\out.gif

Change History (2)

comment:1 Changed 13 years ago by warmerdam

Component: defaultGDAL_Raster
Resolution: invalid
Status: newclosed

Christopher,

This is operating as intended. The -a_srs is used to override the SRS from the source dataset, but it is not intended to reproject the image. It is essentially for the case where the input SRS is missing or wrong, and you want to apply/assign a correct SRS to go with the existing geotransform.

comment:2 Changed 13 years ago by condit

Hi Frank- Sorry about the spurious bug. I was confused by the wording in the documentation: "Override the projection for the output file". I see I should be using gdalwarp for this.

Thanks, -Chris

Note: See TracTickets for help on using tickets.