Changes between Initial Version and Version 1 of Ticket #1234


Ignore:
Timestamp:
Jan 9, 2010, 10:48:31 AM (13 years ago)
Author:
Mateusz Łoskot
Comment:

If this idea is considered for inclusion at all, I think there is no need to cache the block pixel offset value. I'd also suggest to rename the proposed functions to follow naming convention of GetXOff and GetYOff but indicating pixel level offset:

int GetXPixelOff() { return nXOff * nXSize; }
int GetYPixelOff() { return nYOff * nYSize; }

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1234

    • Property Cc Mateusz Łoskot added
  • Ticket #1234 – Description

    initial v1  
    1 {{{
    21I'm developing an application that operates on rasters at the block level and it would be very convenient if each GDALRasterBlock could return its starting pixel. This information can obviously be calculated and stored apart from the block (as I'm currently doing), but it would be nice if each block took care of this itself. If no one objects, I'd appreciate changes similar to the following.
    32
     3{{{
    44--- gdal_priv.h 2006-05-24 17:25:33.000000000 -0500
    55+++ gdal_priv.h 2006-07-11 20:31:37.000000000 -0500
     
    3535 
    3636 /************************************************************************/
     37}}}
    3738
    3839D.
    39 }}}