Opened 9 years ago

Closed 9 years ago

#3184 closed bug (duplicate)

Strange behavior of dissolve tool

Reported by: dr Owned by: cfarmer
Priority: major: does not work as expected Milestone: Version 1.6.0
Component: MapCanvas Version: Trunk
Keywords: Cc: dr, gislab, alexbruy
Must Fix for Release: Yes Platform: All
Platform Version: Awaiting user input: no

Description

There are two layers in attachment. Both layers looks the same. Try to dissolve these layers. Layer with "clear" name dissolves flawlessly, but "unclear" layer represents one polygon with not dissolved boundary.

Attachments (1)

dissolve.zip (2.7 KB) - added by dr 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by dr

Attachment: dissolve.zip added

comment:1 Changed 9 years ago by borysiasty

Owner: changed from borysiasty to cfarmer

comment:2 Changed 9 years ago by dr

Component: Python plugins and bindingsMapCanvas

It is becoming more clear to me. If open attribute table "clear" and "unclear" and copy attribute to clipboard, may see that precision of WKT geometries is 6 number of digit after comma and "clear"'s and "unclear"'s WKT represents of geometries looks the same. But If export this data into PostGIS database and take a look on WKT geometries may see that precision of WKT geometries is 8 number of digit after comma and "clear"'s and "unclear"'s WKT geometries is differently. I guess, that in QGIS precision of geometries using in dissolve tools and while rendering is different values. Is it possible to do them the same for possibility to distinguish nodes more precisely?

comment:3 Changed 9 years ago by cfarmer

Resolution: duplicate
Status: newclosed

This is really a duplicate of #3126, and appears to boil down to the precision of the layers, rather than an actual problem with the dissolve tool. Unlike Arc*, QGIS (and GEOS) do not use any tolerance when unioning geometries (which is what the dissolve tool uses). As such, layers with 'nearly' identical geometries will not be dissolved as if they were identical. A solution to this is to use the simplify tool beforehand, or to reduce the precision of your vector layers.

I am going to close this one as duplicate.

Carson

Note: See TracTickets for help on using tickets.