Ticket #57 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

AIX 5.3 compile fails for pj_mutex.c in proj v4.7.0

Reported by: sfishback Owned by: warmerdam
Priority: major Milestone:
Component: default Version: 4.7.0
Keywords: Cc:

Description

./configure --prefix=/afs/isis/pkg/proj-4.7.0j-4.7.0

checking for a BSD-compatible install... ./install-sh -c checking whether build environment is sane... yes checking for a thread-safe mkdir -p... ./install-sh -c -d checking for gawk... no checking for mawk... no checking for nawk... nawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking for gcc... xlc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... no checking whether xlc accepts -g... yes checking for xlc option to accept ISO C89... none needed checking for style of include used by make... GNU checking dependency style of xlc... none checking for a BSD-compatible install... ./install-sh -c checking whether ln -s works... yes checking whether make sets $(MAKE)... (cached) yes checking build system type... powerpc-ibm-aix5.3.0.0 checking host system type... powerpc-ibm-aix5.3.0.0 checking for a sed that does not truncate output... /bin/sed checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for non-GNU ld... /bin/ld checking if the linker (/bin/ld) is GNU ld... no checking for /bin/ld option to reload object files... -r checking for BSD-compatible nm... /bin/nm -B checking how to recognize dependent libraries... pass_all checking how to run the C preprocessor... xlc -E checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking dlfcn.h usability... yes checking dlfcn.h presence... yes checking for dlfcn.h... yes checking whether we are using the GNU C++ compiler... no checking whether xlC accepts -g... yes checking dependency style of xlC... none checking how to run the C++ preprocessor... xlC -E checking for g77... no checking for xlf... xlf checking whether we are using the GNU Fortran 77 compiler... no checking whether xlf accepts -g... yes checking the maximum length of command line arguments... 18432 checking command to parse /bin/nm -B output from xlc object... ok checking for objdir... .libs checking for ar... ar checking for ranlib... ranlib checking for strip... strip checking for xlc option to produce PIC... checking if xlc static flag -bnso -bI:/lib/syscalls.exp works... no checking if xlc supports -c -o file.o... yes checking whether the xlc linker (/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... aix5.3.0.0 ld.so checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... no checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no configure: creating libtool appending configuration tag "CXX" to libtool checking whether the xlC linker (/bin/ld) supports shared libraries... yes checking for xlC option to produce PIC... checking if xlC static flag -bnso -bI:/lib/syscalls.exp works... no checking if xlC supports -c -o file.o... yes checking whether the xlC linker (/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... aix5.3.0.0 ld.so checking how to hardcode library paths into programs... immediate appending configuration tag "F77" to libtool checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no checking for xlf option to produce PIC... checking if xlf static flag -bnso -bI:/lib/syscalls.exp works... no checking if xlf supports -c -o file.o... yes checking whether the xlf linker (/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... aix5.3.0.0 ld.so checking how to hardcode library paths into programs... immediate checking for exp in -lm... yes checking for ANSI C header files... (cached) yes checking jni.h usability... no checking jni.h presence... no checking for jni.h... no checking whether to enable Java/JNI support... disabled checking for mutexes... enabled, pthread configure: creating ./config.status config.status: creating Makefile config.status: creating src/Makefile config.status: creating man/Makefile config.status: creating man/man1/Makefile config.status: creating man/man3/Makefile config.status: creating nad/Makefile config.status: creating jniwrap/Makefile config.status: creating jniwrap/org/Makefile config.status: creating jniwrap/org/proj4/Makefile config.status: creating src/proj_config.h config.status: src/proj_config.h is unchanged config.status: executing depfiles commands

$ make < ... deleted lines ... >

xlc -DHAVE_CONFIG_H -I. -DPROJ_LIB=\"/afs/isis/pkg/proj-4.7.0/share/proj\" -DMUTEX_pthread -g -c pj_gridlist.c -DPIC -o .libs/pj_gridlist.o

source='jniproj.c' object='jniproj.lo' libtool=yes DEPDIR=.deps depmode=none /bin/sh ../depcomp /bin/sh ../libtool --tag=CC --mode=compile xlc -DHAVE_CONFIG_H -I. -DPROJ_LIB=\"/afs/isis/pkg/proj-4.7.0/share/proj\" -DMUTEX_pthread -g -c -o jniproj.lo jniproj.c

xlc -DHAVE_CONFIG_H -I. -DPROJ_LIB=\"/afs/isis/pkg/proj-4.7.0/share/proj\" -DMUTEX_pthread -g -c jniproj.c -DPIC -o .libs/jniproj.o

"jniproj.c", line 197.7: 1506-356 (W) Compilation unit is empty.

source='pj_mutex.c' object='pj_mutex.lo' libtool=yes DEPDIR=.deps depmode=none /bin/sh ../depcomp /bin/sh ../libtool --tag=CC --mode=compile xlc -DHAVE_CONFIG_H -I. -DPROJ_LIB=\"/afs/isis/pkg/proj-4.7.0/share/proj\" -DMUTEX_pthread -g -c -o pj_mutex.lo pj_mutex.c

xlc -DHAVE_CONFIG_H -I. -DPROJ_LIB=\"/afs/isis/pkg/proj-4.7.0/share/proj\" -DMUTEX_pthread -g -c pj_mutex.c -DPIC -o .libs/pj_mutex.o

"pj_mutex.c", line 106.24: 1506-343 (S) Redeclaration of core_lock differs from previous declaration on line 917 of "/usr/include/sys/proc.h". "pj_mutex.c", line 106.24: 1506-382 (I) The type "struct {...}" of identifier core_lock differs from previous type "union _complex_lock". make: The error code from the last command is 1.

Stop. make: The error code from the last command is 2. Stop. make: The error code from the last command is 1.

I tired both gcc v4.1.2 compiler and XL C/C++ v10.01 both error with the same message as above.

Change History

Changed 5 years ago by sfishback

  • version changed from unspecified to 4.7.0

Changed 4 years ago by warmerdam

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of #55.

Note: See TracTickets for help on using tickets.