Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1788 closed defect (fixed)

run_test hangs on MSYS

Reported by: pramsey Owned by: pramsey
Priority: medium Milestone: PostGIS 2.0.1
Component: postgis Version: 2.0.x
Keywords: Cc:

Description

the run_simple_test script hangs on the first test.

Change History (3)

comment:1 Changed 7 years ago by pramsey

The problem is "too many stdout pipes". Basically once you get to 16, things hang. The first time I fixed this was by turning a pile of sed calls into a single call. Then strk added a new grep call recently and that put us over the top this time. So I have turned some greps into equivalent single patterns.

comment:2 Changed 7 years ago by pramsey

Resolution: fixed
Status: newclosed

Fixed at r9661

comment:3 Changed 7 years ago by pramsey

Another change slipped in there that breaks things in new ways. Removed at r9662

Note: See TracTickets for help on using tickets.