Opened 7 years ago

Closed 7 years ago

#990 closed defect (fixed)

chroot build method: geonetwork does not start

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: 6.0 beta9, geonetwork
Cc: live-demo@…

Description

The following error happens:

start-geonetwork.sh: 17: ./start_geonetwork.sh: cannot create logs/output.log: permission denied

Change history (8)

comment:1 Changed 7 years ago by kalxas

Summary: Geonetwork does not startupchroot build method: geonetwork does not start

comment:2 Changed 7 years ago by hamish

the install_geonetwork.sh script does:

# fix permissions on installed software
chown -R "$USER_NAME:$USER_NAME" "$GEONETWORK_FOLDER"

it is not allowed to have the user own files outside of /home. before this was just bad practice, now with the new build system, where the user UID changes, it causes errors, as the user (now UID 999 not 1000) can't write to the dir listed above.

the work-around we've been using is to add the user to the "users" group, then

chgrp -R users "$GEONETWORK_FOLDER"/jetty/logs
chmod -R g+w "$GEONETWORK_FOLDER"/jetty/logs
adduser user users

what else besides the logs/ dir needs to be user writable?

thanks, Hamish

comment:3 Changed 7 years ago by hamish

Keywords: geonetwork added

comment:4 Changed 7 years ago by kalxas

still does not work in build8915 after the permission fix.

comment:5 in reply to:  4 Changed 7 years ago by hamish

Replying to kalxas:

still does not work in build8915 after the permission fix.

no permission fix has been applied yet. waiting to hear back on what else besides the logs/ dir needs to be user writable?

Hamish

comment:6 Changed 7 years ago by kalxas

By adding write permission to log folder, the service is able to start, but internal geoserver does not work correctly. Works when all geonetwork folder is writable

comment:7 Changed 7 years ago by hamish

seems to be working now in the r8980 build. (only lightly tested)

Hamish

comment:8 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed in beta10

Note: See TracTickets for help on using tickets.