Opened 7 years ago

Closed 7 years ago

#978 closed defect (fixed)

chroot build method: live session user password should be set to "user"

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: 6.0
Cc: live-demo@…

Description

the default password is empty

Change history (6)

comment:1 Changed 7 years ago by wildintellect

Resolution: fixed
Status: newclosed

Tested in revision [8727] , hash of "user" placed into scripts/casper-bottom/25adduser. Might need to be redone if the original hash ever changes. Note, tested by logging out and logging in since using sude in the live session doesn't ask for password.

comment:2 Changed 7 years ago by kalxas

Priority: majorcritical
Resolution: fixed
Status: closedreopened

I am testing build 8731 and live session does not start at all. I try to login with "user" and password and I cannot login.

comment:3 Changed 7 years ago by kalxas

Since the autologin issue (#988) has been partially solved, this might be a duplicate. I am pretty sure I reopened this ticket due to autologin failure (I was using the correct password and was not able to login...). It seems that the password was set right but login failed due to (#988).

I will activate the fix again and we can confirm on next build.

comment:4 Changed 7 years ago by hamish

note "sudo" in the chroot method does not require a paswd. if you pass it one, like ~/bin/launchassit.sh does, it gets ignored. (so you can even pass 'sudo -S' a wrong one and it'll be ignored.

Hamish

comment:5 Changed 7 years ago by kalxas

Priority: criticalnormal

This is expected in live session. If you logout and try to login again, the user password is valid. Tested in build [8877] and confirmed to work.

comment:6 Changed 7 years ago by kalxas

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.