Opened 7 years ago

Closed 7 years ago

#972 closed defect (fixed)

rasdaman: install script full of ugly

Reported by: hamish Owned by: live-demo@…
Priority: major Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: 6.0, rasdaman
Cc:

Description

Hi,

just looking through the 6.0 beta6 build logs. lots of stuff in the rasdaman install is partially broken:

FIXME: is 'apt-get -f' really needed here? what's broken?
FIXME: please put custom stuff in /usr/local/lib so we can know about deviations from the base install. Better: compile against 12.04's libraries

ln: failed to create symbolic link `/usr/lib/libdf.so.0': File exists
ln: failed to create symbolic link `/usr/lib/libdf.so.0.0.0': File exists
ln: failed to create symbolic link `/usr/lib/libmfhdf.so.0': File exists
ln: failed to create symbolic link `/usr/lib/libmfhdf.so.0.0.0': File exists

./install_rasdaman.sh: 282: ./install_rasdaman.sh: /etc/init.d/rpcbind: not found

The following packages have unmet dependencies.
 default-jre-headless : Depends: openjdk-6-jre-headless (>= 6b23~pre11-1ubuntu1~) but it is not going to be installed
 openjdk-6-jre : Depends: openjdk-6-jre-headless (>= 6b24-1.11.3-1ubuntu0.12.04.1) but it is not going to be installed

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Removing wx-common ...   [needed by others?]

could it be cleaned up before we go to RC?

thanks, Hamish

Change history (6)

comment:1 Changed 7 years ago by kalxas

Priority: normalmajor

Seems that cleaning up has removed hdf library and now rasdaman stops at configuration. Failed to install in beta7

comment:2 Changed 7 years ago by hamish

6.0 beta7 build log:

...
checking for strtoul... yes
configure: using hdf4 library...yes
checking for main in -ldf... no
configure: error: in `/tmp/build_rasdaman/rasdaman':
configure: error: --with-hdf4 was given but libdf.a was not found! Please install.
See `config.log' for more details
ERROR: configure failed.
...

building with static libs?

libhdf4-dev was missing, hopefully fixed with r8576.

Hamish

comment:3 Changed 7 years ago by misev

This solution won't work, because when you install libhdf4-dev, libgdal-dev will be removed.

Either

  • leave the symlinks, or
  • remove --with-hdf4 in the configure command (it's not so essential anyway), or
  • use the latest rasdaman from the git repo, where this bug should be fixed

comment:4 Changed 7 years ago by hamish

Hi,

ok, try r8579 where --with-hdf4 has been removed. Note there is also a libhdf4-alt-dev, maybe that helps. If you get really stuck with the hdf4 stuff you might try pinging Frankie on the DebianGIS list who did a lot of the packaging. It is much preferable to stick with released versions (i.e. known and tested codebases). The symlinks I commented out all weren't being created anyway (see the errors in the build log), since the target libs already existed there. I suspect some temporary LD_LIBRARY_PATH magic may have helped instead of symlinks.

From here y'all will have to sort the rest of it out, I'm off to a remote field station for a few days. :)

best, Hamish

comment:5 Changed 7 years ago by kalxas

I just tested building rasdaman with latest trunk in beta7 and WCPS demo fails again. Compilation completed without problems.

comment:6 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

fixed and confirmed in beta8. Works from live session too

Note: See TracTickets for help on using tickets.