Opened 7 years ago

Closed 7 years ago

#959 closed defect (fixed)

geomajas installs old version on OSGeo-Live

Reported by: camerons Owned by: kalxas
Priority: normal Milestone: OSGeoLive6.0Final
Component: OSGeoLive Keywords: 6.0, geomajas
Cc: live-demo@…

Description

As of OSGeoLive 6.0beta4, the geomajas install script [1] installs version 1.8.0 rather than the latest stable version of 1.11.

[1] https://svn.osgeo.org/osgeo/livedvd/gisvm/trunk/bin/install_geomajas.sh

We believe that this is also linked to geomajas not working in 6.0beta4 when the Java Advanced Imaging (JAI) library was copied into the main java library.

The following email thread [2] should provide insights: On 07/23/2012 08:41 AM, Jody Garnett wrote:

We actually have three things to track here:

  • JAI
  • ImageIO
  • ImageIO-Ext (this will make use of GDAL binaries if they are available on the LD_LIBRARY_PATH, or installed into jre/bin)

I was concerned about GeoMajas? using an older copy of GeoTools?; and ending up requiring a different version of ImageIO-Ext (and thus GDAL) then the other projects.

From a recent announcement (http://www.geomajas.org/node/629) it looks like GeoTools? 2.7.5 is expected. This release of GeoTools? (http://jira.codehaus.org/secure/ReleaseNote.jspa?projectId=10270&version=18236) works with ImageIO 1.1.x stream and should be compatible with the same ImageIO-Ext as GeoServer? and uDig (which are starting to make use of GeoTools? 8).

Hi Jody,

Geomajas on the DVD is still in version 1.8.0. The link you provided was referring to Geomajas 1.11.0

[2] http://lists.osgeo.org/pipermail/live-demo/2012-July/005618.html

Change history (6)

comment:1 Changed 7 years ago by camerons

Further background:

  • OSGeoLive is now using OpenJDK 7.
  • We notice that geomajas seems to be installed along with Jetty. Is this required, or can we make use of an existing Java Servlet container already on OSGeo-Live? (Space is at a premium, and we have needed to removed applications from the DVD to make space).
  • This issue is related to: https://trac.osgeo.org/osgeo/ticket/922 udig includes a custom java jvm

comment:2 Changed 7 years ago by kalxas

Priority: blockercritical

Geomajas is working great in beta4. Still at version 1.8.0. I am giving this the same priority as #922 since they are related.

comment:3 Changed 7 years ago by kalxas

I installed the latest geomajas war in beta4 while having JAI files in the java path. Restarted Tomcat and Geomajas seems to work fine. The problem is that war file does not contain the showcase application. Can someone from the project provide those files?

comment:4 Changed 7 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Priority: criticalnormal
Status: newassigned

ok things are more clear now: geomajas actually does not have a showcase release more recent than 1.8.0. Only documentation release is more recent. Committed fix in rev [8360]

comment:5 Changed 7 years ago by hamish

Cc: live-demo@… added

comment:6 Changed 7 years ago by kalxas

Resolution: fixed
Status: assignedclosed

fix confirmed in beta5

Note: See TracTickets for help on using tickets.