Opened 7 years ago

Closed 7 years ago

#936 closed defect (fixed)

tilelite demo issue

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive6.0Final
Component: OSGeoLive Keywords: 6.0, tilelite
Cc: live-demo@…, springmeyer

Description

I am getting pink tiles in Mapnik & Tilelite demo page (as described in Quickstart). To reproduce this:

  1. Use 6.0beta1
  2. Reinstall mapnik using #sudo ~/gisvm/bin/install_mapnik.sh
  3. Start Maptile
  4. Visit http://localhost/mapnik/openlayers.html

Change history (13)

comment:1 Changed 7 years ago by kalxas

correction: step 3: Start Mapnik & Tilelite

comment:2 Changed 7 years ago by kalxas

still here in beta2

comment:3 Changed 7 years ago by kalxas

Priority: majornormal

mapnik is confirmed to be working by Hamish. This is just a demo problem.

comment:4 Changed 7 years ago by kalxas

Milestone: OSGeoLive6.0Final

comment:5 Changed 7 years ago by hamish

I get a Google API key error. I can go to the OSM tiles from the openlayers menu in the top-right "(+", but no population demo there.

Hamish

comment:6 Changed 7 years ago by kalxas

Priority: normalmajor

we need to attract more attention to this...

comment:7 Changed 7 years ago by hamish

Cc: springmeyer added

[cc Dane]

Hi,

If I scroll back in the debug terminal I notice this, with a Broken Pipe:

...
[TileLite Debug] --> Zoom,X,Y: 3,3,3
[TileLite Debug] --> scale_denom: 69885283.0036
127.0.0.1 - - [26/Jul/2012 10:29:18] "GET /3/3/3.png HTTP/1.1" 200 -
[TileLite Debug] --> Zoom,X,Y: 3,4,3
[TileLite Debug] --> scale_denom: 69885283.0036
127.0.0.1 - - [26/Jul/2012 10:29:20] "GET /3/4/3.png HTTP/1.1" 200 -
----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 60453)
Traceback (most recent call last):
  File "/usr/lib/python2.7/SocketServer.py", line 284, in _handle_request_noblock
    self.process_request(request, client_address)
  File "/usr/lib/python2.7/SocketServer.py", line 310, in process_request
    self.finish_request(request, client_address)
  File "/usr/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib/python2.7/SocketServer.py", line 640, in __init__
    self.finish()
  File "/usr/lib/python2.7/SocketServer.py", line 693, in finish
    self.wfile.flush()
  File "/usr/lib/python2.7/socket.py", line 303, in flush
    self._sock.sendall(view[write_offset:write_offset+buffer_size])
error: [Errno 32] Broken pipe
----------------------------------------
[TileLite Debug] --> Zoom,X,Y: 3,3,4
[TileLite Debug] --> scale_denom: 69885283.0036
127.0.0.1 - - [26/Jul/2012 10:29:21] "GET /3/3/4.png HTTP/1.1" 200 -
[TileLite Debug] --> Zoom,X,Y: 3,4,4
[TileLite Debug] --> scale_denom: 69885283.0036
127.0.0.1 - - [26/Jul/2012 10:29:21] "GET /3/4/4.png HTTP/1.1" 200 -
[TileLite Debug] --> Zoom,X,Y: 3,3,2
...

the tilelite files to look at are:

/usr/local/bin/liteserv.py /usr/local/lib/python2.7/dist-packages/tilelite.py

also, I can't see where the .py to set the Google API key. (e.g. a personal one for testing)

Google has disabled use of the Maps API for this application. The
provided key is not a valid Google API Key, or it is not authorized
for the Google Maps Javascript API v2 on this site. If you are the
owner of this application, you can learn about obtaining a valid
key here: http://code.google.com/apis/maps/documentation/javascript/v2/introduction.html#Obtaining_Key

?

thanks, Hamish

comment:8 Changed 7 years ago by hamish

Keywords: tilelite added

comment:9 Changed 7 years ago by olt

FYI: The "Bropen Pipe" errors are ok. That happens when the client (browser) requests a tile and closes the connection before the tile was completely transfered (e.g. the user zoomed in and the tile is no longer needed).

comment:10 in reply to:  9 Changed 7 years ago by hamish

Replying to olt:

FYI: The "Bropen Pipe" errors are ok. That happens when the client (browser) requests a tile and closes the connection before the tile was completely transfered (e.g. the user zoomed in and the tile is no longer needed).

ah, ok, that's probably that then.

so how then to debug it? I don't see anything in any of the usual /var/log files.

thanks, Hamish

comment:11 Changed 7 years ago by wildintellect

So the issue is with the Javascript. Basically it was calling the tiles as an OSM source, I switched it to an XYZ, since the latest openlayers treats that differently. I also pointed the sample to the local installs of OL and Jquery so the demo works 100% offline. See app-conf/mapnik/local.html

Fix committed, docs url updated to local.html. Can someone please verify and then close this ticket.

comment:12 Changed 7 years ago by kalxas

Priority: majornormal

Thanks Alex for the fix. We will confirm in next build and close this.

comment:13 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

fix confirmed in beta5

Note: See TracTickets for help on using tickets.