Opened 7 years ago

Closed 7 years ago

#934 closed defect (fixed)

rasdaman demo not working as expected

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: 6.0
Cc: live-demo@…

Description

rasdaman fails to start in 6.0beta1 due to failure of start_rasdaman.sh

Change history (29)

comment:1 Changed 7 years ago by kalxas

Type: taskdefect

comment:2 Changed 7 years ago by rasdaman

Resolution: fixed
Status: newclosed

The bug is fixed by updating the host name in the rasdaman configuration file rasmgr.conf.

comment:3 Changed 7 years ago by kalxas

confirmed to build and work post beta1. Thanks for the fix

comment:4 Changed 7 years ago by rasdaman

or manually run sed -i -e "s/ -host [ ]*/ -host osgeolive/" /user/local/rasdaman/etc/rasmgr.conf start_rasdaman.sh

will fix the problem

comment:5 Changed 7 years ago by rasdaman

should be /usr/local/rasdaman/etc/rasmgr.conf

comment:6 Changed 7 years ago by kalxas

Resolution: fixed
Status: closedreopened

I get a failure in WCPS demo in beta2 even after running the above fix

comment:7 Changed 7 years ago by misev

Did you restart rasdaman after applying the fix?

stop_rasdaman.sh start_rasdaman.sh

comment:8 Changed 7 years ago by kalxas

yes, still having the same problem.

comment:9 Changed 7 years ago by kalxas

can this patch be applied in svn trunk so I can install from scrach?

comment:10 Changed 7 years ago by rasdaman

Actually, it's in the patch already. I rerun the install_rasdaman.sh, and then the bug gone.

comment:11 Changed 7 years ago by kalxas

thanks, I will reinstall and confirm this closed

comment:12 Changed 7 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

ok, I reinstalled and now works. Thanks.

comment:13 Changed 7 years ago by kalxas

Resolution: fixed
Status: closedreopened

This issue reappeared in build8192. There are some failures in rasdaman build: http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-6.0build8192-log.tar.gz

I checked rasmgr.conf and osgeolive is not defined again as host. I am thinking that the above fix only works on second run of the script and this is why it worked for me before. But on a clean build it appeared again.

We really want this one closed in order to reach RC. Any ideas?

Regards, Angelos

comment:14 Changed 7 years ago by kalxas

Summary: rasdaman start script failsrasdaman demo not working as expected

Just tested on build 8234 and seems that only WCPS fails to execute. Also NDVI demo has a slider on top that is not working (I assume it is used for thresholding the NDVI index).

comment:15 Changed 7 years ago by rasdaman

The hostname return an empty result for rasmgr.conf. Have used the hardcoded host name. (have committed the changed)

The demo should work after restart the rasdaman.

comment:16 Changed 7 years ago by kalxas

I am still getting problems with rasdaman demo on beta4: http://aiolos.survey.ntua.gr/gisvm/6.0/osgeo-live-mini-6.0beta4.iso

Can you please confirm with this latest build? I am wondering what is wrong with the installation.

comment:17 Changed 7 years ago by kalxas

Another issue is that the startup_rasdaman.sh script fails to run on iso due to permissions.

comment:18 Changed 7 years ago by kalxas

Milestone: OSGeoLive6.0RC1
Priority: majorminor

This was fixed by rasdaman in rev [8316] and confirmed by me to work on beta4. I am keeping this open until next build.

comment:19 Changed 7 years ago by hamish

Hi,

chown user "$RASDAMAN_HOME"/etc/

don't do that, the user name may change.

instead try something like

chgrp users "$RASDAMAN_HOME"/etc/
chmod g+w "$RASDAMAN_HOME"/etc/

what was wrong with the rc.local solution that solved it for the last release? the hostname may not be known until boot time.

thanks, Hamish

comment:20 in reply to:  19 Changed 7 years ago by hamish

Replying to hamish:

don't do that, the user name may change.

or more to the point, the UID.

comment:21 Changed 7 years ago by misev

The rc.local solution didn't work either for the last release as I remember.

I've suggested now to put the sed into the script that starts rasdaman (start_rasdaman.sh), hopefully we can have an out of the box running rasdaman for this release.

comment:22 in reply to:  19 Changed 7 years ago by hamish

Replying to hamish:

Hi,

chown user "$RASDAMAN_HOME"/etc/

don't do that, the user name may change.

instead try something like

chgrp users "$RASDAMAN_HOME"/etc/
chmod g+w "$RASDAMAN_HOME"/etc/

"$USER_NAME" is no good either; do something like the above if you don't like the rc.local solution. otherwise it fails for any other user created post-build. Also, "user" should (must?) not be the primary owner of anything outside of /home/user.

thanks, Hamish

comment:23 in reply to:  21 Changed 7 years ago by hamish

Hi,

Replying to misev:

The rc.local solution didn't work either for the last release as I remember.

you're right, it didn't. but your interim solution of changing $HOSTNAME to `hostname` does work, and is preferable to having the user change it at run time. (I've got a 5.5 VM open now & have just tested it)

thanks, Hamish

comment:24 Changed 7 years ago by hamish

(i.e. `hostname` in rc.local) why didn't it like localhost again? should we be changing /etc/hosts?

comment:25 Changed 7 years ago by misev

If it works all is fine then :-)

There's some check in the server of the host name, which is not localhost normally, so it only starts if the right hostname is set in the configuration.

comment:26 Changed 7 years ago by kalxas

Priority: minornormal

I just changed permissions to root owning the folder but anyone can change rasmgr.conf and that works fine here. If the rc.local issue does not work, lets leave it as is for now.

comment:27 Changed 7 years ago by rasdaman

current solution works. Acturally, both are fine.

comment:28 Changed 7 years ago by kalxas

broken again by rev [8398]. Permissions are not working Hamish...

comment:29 Changed 7 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

fix confirmed in beta5

Note: See TracTickets for help on using tickets.