Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#759 closed defect (fixed)

starting mapnik on osgeo-live doesn't work

Reported by: camerons Owned by: live-demo@…
Priority: major Milestone:
Component: OSGeoLive Keywords: 5.0, mapnik
Cc:

Description

We have a number of issues with mapnik on OSGeo-Live:

I ran the Mapnik quickstart, starting from "Mapnik & Openlayers" heading. Click Desktop -> Spatial Tools -> Start Mapnik & TileLite? Then tried opening http://localhost:8000 This URL returns an error, "Unable to connect"

Then, the following URL has changed (quickstart needs to be updated): wrong: http://localhost/mapnik/demo/openlayers.html correct to: http://localhost/mapnik/openlayers.html

And the contents of new page doesn't load (it only gets a title) (probably because http://localhost:8000 didn't load)

Change history (4)

comment:1 in reply to:  description Changed 8 years ago by hamish

Replying to camerons:

I ran the Mapnik quickstart, starting from "Mapnik & Openlayers" heading. Click Desktop -> Spatial Tools -> Start Mapnik & TileLite? Then tried opening http://localhost:8000 This URL returns an error, "Unable to connect"

it should be port 8012. fixed in svn. (en quickstart)

note sahana also uses port 8000.

Then, the following URL has changed (quickstart needs to be updated): wrong: http://localhost/mapnik/demo/openlayers.html correct to: http://localhost/mapnik/openlayers.html

fixed in svn. (en quickstart)

And the contents of new page doesn't load (it only gets a title) (probably because http://localhost:8000 didn't load)

works for me.

Hamish

comment:2 Changed 8 years ago by darkblueb

http://localhost:8012 works for me - RC1

comment:3 Changed 8 years ago by hamish

Keywords: 5.0 mapnik5.0, mapnik
Resolution: fixed
Status: newclosed

comment:4 Changed 8 years ago by springmeyer

@hamish - was just about to take a look at this. thanks for clearing things up.

Note: See TracTickets for help on using tickets.