Opened 4 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#2164 closed defect (invalid)

rasdaman demo page not working

Reported by: darkblueb Owned by: osgeolive@…
Priority: major Milestone: OSGeoLive13.0
Component: OSGeoLive Keywords: rasdaman
Cc:

Description

The web page localhost/rasdaman-demo shows an interface, but selecting several tests did not complete as expected. [ rasql, 2D, Convolution ]

Change history (7)

comment:1 Changed 4 weeks ago by kalxas

Priority: normalmajor

comment:2 Changed 3 weeks ago by misev

The problem is that service tomcat8 is not started on startup. It should be enabled to automatically start on boot.

On the iso there's an automatically generated systemd tomcat8.service in /run/systemd/generator.late/tomcat8.service. This can be copied to /etc/systemd/system and enabled on startup. In total this should be done:

sudo cp /run/systemd/generator.late/tomcat8.service /etc/systemd/system
sudo systemctl enable tomcat8.service

I'm not sure in what install_* script should this be done though.

comment:3 Changed 3 weeks ago by kalxas

The tomcat8 service is not started by default because we do not want the memory allocation to be high on startup. The launchers of 52N, rasdaman and ncWMS make sure to start the service.

This has not changed from the previous releases.

comment:4 Changed 3 weeks ago by misev

Ok but then this ticket is not valid: darkblueb didn't run the rasdaman start launcher before the demo?

comment:5 Changed 3 weeks ago by kalxas

Resolution: invalid
Status: newclosed

I just tested on beta3 and everything works fine. The user needs to start rasdaman, wait a couple of minutes for tomcat to startup and then launch the rasdaman demo.

comment:6 Changed 3 weeks ago by misev

I'm not sure if this process is entirely clear to the user (e.g. darkblueb wasn't aware).

Should we maybe make the demo launcher itself automatically start tomcat and rasdaman? And maybe show a temporary popup that it may take a few minutes until tomcat initializes.

comment:7 Changed 3 weeks ago by kalxas

This is indeed not clear in the quickstart:

https://osgeo.github.io/OSGeoLive-doc/en/quickstart/rasdaman_quickstart.html

Can you please make a pull request to mention the process in the quickstart?

https://github.com/OSGeo/OSGeoLive-doc/blob/master/doc/quickstart/rasdaman_quickstart.rst

Note: See TracTickets for help on using tickets.