Opened 12 months ago

Closed 5 months ago

#2100 closed task (fixed)

Rebase iso to Lubuntu 18.04.2

Reported by: kalxas Owned by: kalxas
Priority: blocker Milestone: OSGeoLive13.0
Component: OSGeoLive Keywords:
Cc:

Description


Change history (8)

comment:2 Changed 12 months ago by darkblueb

12dev build285-master

lsb-release shows DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

comment:3 Changed 12 months ago by kalxas

we still use the 18.04 iso

comment:4 Changed 5 months ago by kalxas

Milestone: OSGeoLive12.0OSGeoLive13.0
Summary: Rebase iso to Lubuntu 18.04.1Rebase iso to Lubuntu 18.04.2

comment:5 Changed 5 months ago by kalxas

I have been trying to get 18.04.2 iso to work with our build process.

Unfortunately there is a major change in the Ubuntu iso since 18.04.1 that breaks our process:

Debian and subsequently Ubuntu has moved to multipart initrd files for the live-boot system.

This means that the initrd.lz file we used to create in bin/build_chroot.sh is now invalid and will cause a kernel panic during boot (see screenshot in https://github.com/OSGeo/OSGeoLive/pull/222).

I am working on a solution for this, more details to follow.

comment:6 Changed 5 months ago by kalxas

Priority: majorblocker

comment:8 Changed 5 months ago by kalxas

Resolution: fixed
Status: assignedclosed

Fix confirmed.

Note: See TracTickets for help on using tickets.