Opened 3 years ago

Closed 3 years ago

#1705 closed defect (fixed)

pycsw capabilities document throws 500 error

Reported by: kalxas Owned by: kalxas
Priority: critical Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords: pycsw, wsgi, geolinks
Cc: live-demo@…

Description


Change history (6)

comment:1 Changed 3 years ago by kalxas

[Fri Jun 03 18:34:45.994370 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010] mod_wsgi (pid=2388): Target WSGI script '/usr/share/pycsw/csw.wsgi' cannot be loaded as Python module., referer:
[Fri Jun 03 18:34:45.994391 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010] mod_wsgi (pid=2388): Exception occurred processing WSGI script '/usr/share/pycsw/csw.wsgi'., referer: 
[Fri Jun 03 18:34:45.994404 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010] Traceback (most recent call last):, 
[Fri Jun 03 18:34:45.994414 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]   File "/usr/share/pycsw/csw.wsgi", line 62, in <module>, referer: http://localhost/pycsw/tests/index.html
[Fri Jun 03 18:34:45.994454 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]     from pycsw import server, 
[Fri Jun 03 18:34:45.994459 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]   File "/usr/lib/python2.7/dist-packages/pycsw/server.py", line 42, in <module>, referer: 
[Fri Jun 03 18:34:45.995499 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]     from pycsw import config, fes, log, metadata, util, sru, oaipmh, opensearch, referer: 
[Fri Jun 03 18:34:45.995506 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]   File "/usr/lib/python2.7/dist-packages/pycsw/metadata.py", line 37, in <module>, referer: 
[Fri Jun 03 18:34:45.995626 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010]     from geolinks.links import sniff_link, referer: http://localhost/pycsw/tests/index.html
[Fri Jun 03 18:34:45.995637 2016] [wsgi:error] [pid 2388] [client 127.0.0.1:39010] ImportError: No module named links, referer: http://localhost/pycsw/tests/index.html

comment:2 Changed 3 years ago by kalxas

Priority: blockercritical

python-geolinks needs to be downgraded to 0.0.1 to be compatible with pycsw 1.x

comment:3 Changed 3 years ago by kalxas

Status: newassigned

pull request submitted upstream.

https://github.com/geopython/pycsw/pull/441

since pycsw 1.10.5 will include this fix, I will patch 1.10.4 in our ppa and DebianGIS.

comment:5 Changed 3 years ago by kalxas

Confirmed fixed after doing

$ apt-get update
$ apt-get install python-pycsw
$ service apache2 restart

in alpha2.

comment:6 Changed 3 years ago by kalxas

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.