Opened 3 years ago

Closed 3 years ago

#1699 closed defect (fixed)

downgrade osgEarth to 2.5

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

Thanks Bas for reporting to mailing list:

QGIS upstream has recently disabled the globle plugin when built with
osgEarth 2.7 [0] because the initial changes were not sufficient to
support anything newer that 2.5 [1]. Proper support for 2.7 has been
merged recently too [2], but has not been backported to 2.14 LTR.

Assuming you want to stick to QGIS 2.14 for OSGeo-Live 10.0, and want to
have a working globe plugin in QGIS, downgrading the osgearth package in
the nightly PPA to 2.5 is needed. You cannot rely on the 2.5 package in
xenial because it needs to be rebuilt with GDAL 2.1.0 in the nightly PPA.

[0]
https://github.com/qgis/QGIS/commit/ddcc2fb82ca6ae3d09e19ce4fe6be689e58886f4
[1] http://hub.qgis.org/issues/12550
[2]
https://github.com/qgis/QGIS/commit/87121d63a8ca28dc75631d3ef6a59c025388a026

Change history (2)

comment:1 Changed 3 years ago by kalxas

Cc: live-demo@… added

comment:2 Changed 3 years ago by kalxas

Resolution: fixed
Status: newclosed

done in nightly ppa

Note: See TracTickets for help on using tickets.