Opened 4 years ago

Closed 3 years ago

#1523 closed defect (fixed)

52nSOS: DescribeSensor fails for "52NorthWS1"

Reported by: ehjuerrens Owned by: ehjuerrens
Priority: normal Milestone: OSGeoLive10.5
Component: OSGeoLive Keywords:
Cc:

Description

When executing describe sensor for procedure "52NorthWS1", the server returns an internal server error message and nothing is logged.

Change history (10)

comment:1 Changed 4 years ago by ehjuerrens

Status: newassigned

The issue is fixed in the latest package but requires confirmation after the next beta or RC build.

comment:2 Changed 4 years ago by kalxas

Milestone: OSGeoLive9.0OSGeoLive9.5

Ticket retargeted after milestone closed

comment:3 Changed 3 years ago by kalxas

Milestone: OSGeoLive9.5OSGeoLive10.0

Ticket retargeted after milestone closed

comment:4 Changed 3 years ago by kalxas

Milestone: OSGeoLive10.0OSGeoLive10.5

comment:5 Changed 3 years ago by ehjuerrens

Resolution: fixed
Status: assignedclosed

The problem still persists and can be fixed with the following call in the command line:

wget https://52north.org/files/sensorweb/osgeo-live/52n-sos-osgeo-live-10.0_fix-sensor.sql && sudo su postgres -c "psql -d 52nSOS -f 52n-sos-osgeo-live-10.0_fix-sensor.sql" && rm -fv 52n-sos-osgeo-live-10.0_fix-sensor.sql

@kalxas: How can I add this to the osgeo-live errata page?

Last edited 3 years ago by ehjuerrens (previous) (diff)

comment:6 Changed 3 years ago by kalxas

Resolution: fixed
Status: closedreopened

@ehjuerrens, we need to fix this on git master before we close the ticket. Can you please send a pull request?

We do not have yet an errata page for 10.0, perhaps we should create one.

comment:7 Changed 3 years ago by ehjuerrens

I am not sure how to create a pull request because there are no changes required in the "code".

Which location do you recommend?

Last edited 3 years ago by ehjuerrens (previous) (diff)

comment:8 Changed 3 years ago by kalxas

Hi,

You have posted above a small script to fix this issue. Can you please integrate it in the 52N-SOS installer and issue a pull request?

https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_52nSOS.sh

comment:9 Changed 3 years ago by ehjuerrens

Hi!

I have update the package that is downloaded during install, hence the script is not required during the creation of a new image file. Therefor, no need to update the install_52nSOS.sh. Just for the already created ones. Hence, I would expect something like a general ERRATA.md or errata.html in the documentation repo.

What do you think?

Kind regards,

Eike

comment:10 Changed 3 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

Hi Eike,

Thanks for the clarification. The last errata page we did was this:

https://wiki.osgeo.org/wiki/Live_GIS_Disc/Errata/8.0

Feel free to start a similar page for 10.0

Best regards, Angelos

Note: See TracTickets for help on using tickets.