Opened 4 years ago

Closed 3 years ago

#1515 closed defect (fixed)

ossim qt and ossim planet need a rebuild on top of new libossim-dev

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive9.5
Component: OSGeoLive Keywords: ossim-qt, ossim-planet
Cc: live-demo@…

Description

In 9.0alpha2, the ossim installer has been updated according to

https://github.com/OSGeo/OSGeoLive/pull/17

In this case the pull request should not have been accepted, since it uses a custom build of ossim, which conflicts with the ossim version in our OSGeoLive ppa:

https://launchpad.net/~osgeolive/+archive/ubuntu/nightly/+packages https://launchpad.net/~osgeolive/+archive/ubuntu/nightly/+sourcepub/5119723/+listing-archive-extra

This conflict causes OTB not to work since it was built against ppa version of ossim.

I see 2 solutions: either build the extra ossim modules using the ppa version of ossim or update the ppa version so that packages do not conflict.

Best, Angelos

Change history (9)

comment:1 Changed 4 years ago by kalxas

Priority: blockercritical

New ossim debian package is now available on OSGeoLive ppa. OTB works fine with this new version.

https://launchpad.net/~osgeolive/+archive/ubuntu/nightly/+sourcepub/5227722/+listing-archive-extra

We now need to build the extra ossim modules (QT4, Planet etc) on top of this version.

comment:2 Changed 4 years ago by kalxas

BTW, ossim installer was taken a step back to use the ppa version:

https://github.com/OSGeo/OSGeoLive/commit/9560b392ed28329ba0bcc0496bb5a8d4534f627d

comment:3 Changed 4 years ago by kalxas

Summary: custom ossim build breaks OTBossim qt and ossim planet need a rebuild on top of new libossim-dev

comment:4 Changed 4 years ago by kalxas

Thanks Massimo for providing the new debian packages for ossim-qt and ossim-plugins. We need to test the latest nightly build to make sure everything works fine.

Pull request: https://github.com/OSGeo/OSGeoLive/pull/39

Nightly build to test: http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-nightly-build143-amd64-6ef02a7.iso

comment:5 Changed 4 years ago by kalxas

I have just tested the latest build (146):

The applications are installed and work fine when launched from desktop shortcuts.

Unfortunately, the Geospatial menu launchers are not working properly (Imagelinker and OssimPlanet?), so this ticket is not yet completely fixed...

comment:6 Changed 4 years ago by kalxas

Resolution: fixed
Status: newclosed

closing this one since the major issue is fixed.

comment:7 Changed 3 years ago by kalxas

Resolution: fixed
Status: closedreopened

After upgrading GDAL to 1.11.3, ossim-qt and ossim-planet deb files need a rebuild again... The installer is disabled in 9.5alpha1 but libossim1 is available due to otb.

comment:8 Changed 3 years ago by kalxas

Keywords: ossim-qt ossim-planet added
Milestone: OSGeoLive9.0OSGeoLive9.5

comment:9 Changed 3 years ago by kalxas

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.