Opened 4 years ago

Closed 4 years ago

#1437 closed defect (fixed)

OL3 fails to install

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

Several build errors in the build log. After installation, only the home page is available (examples are missing)

Change history (9)

comment:1 Changed 4 years ago by kalxas

OpenLayers3 installation folder moved to /var/www/html/ol3 in order to keep the openlayers2 compatibility. The installer still fails to install the examples and docs (tested in build [12080])

comment:2 Changed 4 years ago by asantiago

Is there any log I can see? What is the error?

Note, I updagte the intall_openlayers script to work only with OL3. I saw you make a mix of OL2 and OL3, that nice, but overview and quickstart was modified too to explain only OL3.

comment:3 Changed 4 years ago by kalxas

Hi Antonio,

The logs are saved here, next to each nightly build:

http://aiolos.survey.ntua.gr/gisvm/dev/

Please check the latest:

http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-nightly-build12081-i386-log.tar.gz

in file chroot-build.log

The goal of my modifications was to keep legacy openlayers demos in OSGeoLive from failing. I think it is better to keep only the OL2 JS code under localhost/openlayers and the new version under localhost/ol3 (with examples and docs only for the new version)

Best, Angelos

comment:4 Changed 4 years ago by kalxas

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 2.1.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

comment:5 Changed 4 years ago by asantiago

Looking at the log file it seems the OL3 installation fails because there is not installed npm command line tool (which depends on nodejs).

Installing npm dependencies... ./install_openlayers.sh: 99: ./install_openlayers.sh: npm: not found

Who can that dependency in the VM?

comment:6 Changed 4 years ago by kalxas

Hi Antonio,

Johan has provided a debian package for OL3: http://aiolos.survey.ntua.gr/gisvm/dev/libjs-openlayers3_3.1.1-1_all.deb

I will use this one to install the package to avoid installing npm (due to disk space etc) Let's see how that works out.

Best, Angelos

comment:7 Changed 4 years ago by kalxas

There is also an OL2 package uploaded in our ppa (currently fails to build, but I am sure it will work soon ;). Thanks Johan and Sebastian

https://launchpad.net/~osgeolive/+archive/ubuntu/nightly/+sourcepub/4640207/+listing-archive-extra

comment:8 Changed 4 years ago by kalxas

Fixed and tested locally. Waiting for nightly build [12111] to confirm

comment:9 Changed 4 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed fixed in nightly build [12113]

Note: See TracTickets for help on using tickets.