Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1391 closed defect (fixed)

maptiler: fails on epsg code 900913

Reported by: hamish Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: maptiler, gdal, python bindings, spherical merc
Cc:

Description

Hi,

maptiler tries to use epsg code 900913, but the ImportFromEPSG() code throws an error that it doesn't know it. So the overall operation fails.

I can patch it to request epsg code 3857 instead, and then it works.

But since 900913 will be around for years to come, and is still present in the /usr/share/proj/other.extra epsg file, I'd hope that gdal would not give an error for it, and for the next years consider it a bug that it does.

works in gdal 1.9 but not 1.10:

from osgeo import osr
out_srs = osr.SpatialReference()
out_srs.ImportFromEPSG(900913)

if we do a RC2 I'd suggest to comment out maptiler from the build.

Since we at OSGeo commissioned the gdal2tiles software as part of Google Summer of Code 2008, IMO we have a responsibility and moral right to keep it going. The gdal2tiles.py backend remains alive and maintained in gdal svn, I would suggest to import the last known public version of the wxpy gui frontend to it (ie maptiler) into osgeo's github repo; I notice a couple forks there already (only the French one seems to have any updates to it).

The .deb we are using from googlecode contains the latest version, the svn repo there was abandoned and hidden at an earlier version. Changes to the copy of gdal2tiles in the maptiler deb were never committed to gdal svn, a diff should be made, useful things ported in, and the new maptiler git repo depend on the latest gdal version of the gdal2tiles.py program (which has kept up with changes in OpenLayers?, Google Map tiles, etc).

regards, Hamish

Change history (5)

comment:1 Changed 5 years ago by hamish

patched both installed versions of gdal2tiles.py in r11931.

Hamish

comment:2 Changed 5 years ago by hamish

I tested osgeo-live-nightly-build11850-i386.iso which has gdal 1.11, and it works there, so the problem is gdal 1.10 specific.

Hamish

comment:3 Changed 5 years ago by hamish

comment:4 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

thanks Hamish for the fix

comment:5 Changed 5 years ago by hamish

just to document the remaining problems:

  • output dir is ignored, wants to put the resulting tile tree in the same dir as the input file (fails if read-only)
  • openlayers support is out of date, needs newer gdal2tiles.py from gdal instead of its own embedded one, but some features from the embedded copy need to be merged into the (maintained) gdal swig/python/scripts/ version.

Hamish

Note: See TracTickets for help on using tickets.