Opened 5 years ago

Closed 5 years ago

#1386 closed defect (fixed)

sahaha: login fails

Reported by: hamish Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: sahana
Cc: flavour, rediguana

Description

Hi,

using the credentials given in the quickstart (and install script AFAICS) it's not possible to login to the admin side of the sahana example on the live disc.

??

not a good look.

there are some error messages in the build log worth investigating.

http://aiolos.survey.ntua.gr/gisvm/dev/

python: no process found
WARNING: S3Chart unresolved dependency: matplotlib required for charting
WARNING: S3Msg unresolved dependency: tweepy required for non-Tropo Twitter support
WARNING: Survey unresolved dependency: PyRTF required if you want to export assessment templates as a Word document
Traceback (most recent call last):
  File "/usr/local/lib/web2py/gluon/restricted.py", line 212, in restricted
    exec ccode in environment
  File "applications/eden/models/zzz_1st_run.py", line 177, in <module>
    resource.import_xml(File, format="csv", stylesheet=stylesheet)
  File "applications/eden/modules/s3/s3resource.py", line 2465, in import_xml
    raise SyntaxError(xml.error)
SyntaxError: Forbidden variable
./install_sahana.sh: 317: ./install_sahana.sh: cannot create /etc/apache2/conf.d/sahana: Directory nonexistent

what has /etc/apache2/conf.d/ changed to for ubuntu 14.04?

thanks, Hamish

Change history (5)

comment:1 Changed 5 years ago by hamish

apache conf updated to modern ubuntu way in r11797.

I note ZOO writes directly to conf-enabled/ instead of conf-available/ + a2enconf zoo-project.conf.

Hamish

comment:2 Changed 5 years ago by hamish

nope, still "Invalid login".

python: no process found

that just comes from a "killall python". (perhaps not the safest thing to be calling as we may be running something else in the background...)

maybe a

  if [ `pgrep -c python` -gt 0 ] ; then

could quieten that.

this seems to be a web2py thing, but fwiw re. SyntaxError: Forbidden variable,

http://stackoverflow.com/questions/9746838/why-cant-attribute-names-be-python-keywords

also to note, fwiw, that matplotlib gets installed earlier by install_ipython.sh, not sure why S3Chart doesn't see it.

I'm not sure how to ensure that eden/models/zzz_1st_run.py gets run, or where to look in the Sahana PG database to see if it worked (I'm looking, but I don't see it in any of the auth tables).

thanks, Hamish

comment:3 Changed 5 years ago by hamish

still no joy in the latest nightly iso build. can't log in.

http://aiolos.survey.ntua.gr/gisvm/dev/

Fran? we ship in a couple days..

thanks, Hamish

comment:4 Changed 5 years ago by hamish

ok, with help from Michael H., tried pulling the latest web2py and sahana-eden git HEADs and now and login works as expected.

I just removed the /usr/local/lib/web2py dir and reran the install_sahana.sh script, the real test will be the next nightly iso build..

n.b. web2py 2.7.4-stable or newer is apparently recommended. Ubuntu 14.04 provides python-web2py 1.99.7, perhaps for the next release can pypi-install create a deb, although right now pypi.python.org is sitting at version 2.1.1, so still too old.

Hamish

comment:5 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed fixed in build [11868]

Note: See TracTickets for help on using tickets.