Opened 5 years ago

Closed 5 years ago

#1355 closed defect (fixed)

Iris fails to build in 14.04

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

/usr/bin/python tools/generate_std_names.py etc/cf-standard-name-table.xml build/lib.linux-i686-2.7/iris/std_names.py Traceback (most recent call last):

File "setup.py", line 237, in <module>

'std_names': MakeStdNames?, 'pyke_rules': MakePykeRules?},

File "/usr/lib/python2.7/distutils/core.py", line 151, in setup

dist.run_commands()

File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands

self.run_command(cmd)

File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command

cmd_obj.run()

File "/usr/lib/python2.7/distutils/command/install.py", line 601, in run

self.run_command('build')

File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command

self.distribution.run_command(command)

File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command

cmd_obj.run()

File "/usr/lib/python2.7/distutils/command/build.py", line 128, in run

self.run_command(cmd_name)

File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command

self.distribution.run_command(command)

File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command

cmd_obj.run()

File "setup.py", line 202, in run

MakePykeRules?._pyke_rule_compile()

File "setup.py", line 155, in _pyke_rule_compile

import iris.fileformats._pyke_rules

File "build/lib.linux-i686-2.7/iris/init.py", line 106, in <module>

import iris.cube

File "build/lib.linux-i686-2.7/iris/cube.py", line 35, in <module>

import iris.analysis

File "build/lib.linux-i686-2.7/iris/analysis/init.py", line 38, in <module>

import iris.coords

File "build/lib.linux-i686-2.7/iris/coords.py", line 33, in <module>

import iris.aux_factory

File "build/lib.linux-i686-2.7/iris/aux_factory.py", line 28, in <module>

from iris._cube_coord_common import CFVariableMixin

File "build/lib.linux-i686-2.7/iris/_cube_coord_common.py", line 24, in <module>

import iris.unit

File "build/lib.linux-i686-2.7/iris/unit.py", line 34, in <module>

import netcdftime

ImportError?: No module named netcdftime touch: cannot touch '/usr/local/lib/python2.7/dist-packages/Iris-1.4.0-py2.7-linux-i686.egg/iris/fileformats/_pyke_rules/compiled_krb/*': No such file or directory

Change history (15)

comment:1 Changed 5 years ago by ian

Resolution: fixed
Status: newclosed

I've been unable to duplicate this error - it looks like the NetCDF dependency did not download for you, and was therefore missing when you tried to build Iris. It would be useful to see the whole build log to confirm this.

I've updated Iris to the most recent version and it builds correctly. I'm working on the quick start page.

comment:2 Changed 5 years ago by kalxas

Resolution: fixed
Status: closedreopened

Hi Ian,

"import iris" from a Python console throws an error: no module named iris

comment:3 Changed 5 years ago by kalxas

Also the quickstart is pointing to an online resource... all projects should follow the template and provide some small quickstart for users to follow, even when internet connection is unavailable.

comment:4 Changed 5 years ago by kalxas

Debian packaging started with cartopy:

https://launchpad.net/~osgeolive/+archive/ubuntu/nightly/+sourcepub/4322446/+listing-archive-extra

This way we will avoid all those unnecessary numpy builds etc, plus less build time for the iso ;)

comment:6 Changed 5 years ago by kalxas

Started Iris debian package but I am getting this error:

https://launchpadlibrarian.net/181056516/buildlog_ubuntu-trusty-i386.iris_1.6.1-0~trusty1_FAILEDTOBUILD.txt.gz

copying lib/iris/tests/results/cube_collapsed/latitude_time_dual_stage.data.0.npy -> build/lib.linux-i686-2.7/iris/tests/results/cube_collapsed
copying lib/iris/fileformats/_pyke_rules/fc_rules_cf.krb -> build/lib.linux-i686-2.7/iris/fileformats/_pyke_rules
copying lib/iris/tests/stock_mdi_arrays.npz -> build/lib.linux-i686-2.7/iris/tests
copying lib/iris/tests/stock_arrays.npz -> build/lib.linux-i686-2.7/iris/tests
/usr/bin/python tools/generate_std_names.py etc/cf-standard-name-table.xml build/lib.linux-i686-2.7/iris/std_names.py
Traceback (most recent call last):
  File "setup.py", line 252, in <module>
    'std_names': MakeStdNames, 'pyke_rules': MakePykeRules},
  File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/distutils/command/build.py", line 128, in run
    self.run_command(cmd_name)
  File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "setup.py", line 217, in run
    MakePykeRules._pyke_rule_compile()
  File "setup.py", line 170, in _pyke_rule_compile
    import iris.fileformats._pyke_rules
  File "build/lib.linux-i686-2.7/iris/__init__.py", line 107, in <module>
    import iris.cube
  File "build/lib.linux-i686-2.7/iris/cube.py", line 35, in <module>
    import iris.analysis
  File "build/lib.linux-i686-2.7/iris/analysis/__init__.py", line 41, in <module>
    import iris.coords
  File "build/lib.linux-i686-2.7/iris/coords.py", line 31, in <module>
    import netcdftime
ImportError: No module named netcdftime
dh_auto_build: python setup.py build --force returned exit code 1
make: *** [build] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20140730-1154
FAILED [dpkg-buildpackage died]
******************************************************************************

Thoughts?

comment:7 Changed 5 years ago by kalxas

Debian files are available here:

https://github.com/kalxas/iris/blob/1254-deb/debian/

Dependencies are listed here: https://github.com/kalxas/iris/blob/1254-deb/debian/control

Am I missing something?

comment:8 Changed 5 years ago by kalxas

Perhaps Iris is not compatible with python-netcdf provided with 14.04? I see that it requires netCDF4...

comment:11 Changed 5 years ago by kalxas

Hi Ian,

I have seen that you install netCDF again [11634] after my debian packages commit [11633]. Did you test the python-netcdf4 package and it is not working?

comment:12 Changed 5 years ago by ian

Hi Angelos

We must have been working on this around the same time - I missed your commit when I finally did an svn up and modified install_iris.sh (I don't check my email very thoroughly on days off so I didn't see the trac update...).

I suspect you python-netcdf4 will work perfectly, could you put it back to how it was?

Great work with the packaging. I will do a proper quickstart,

Ian

comment:13 Changed 5 years ago by kalxas

Priority: criticalmajor

Hi Ian,

No problem :) import iris is now working on the disk after the new deb packages... of course we need someone to take the new iso for a spin in order to close this ticket... http://aiolos.survey.ntua.gr/gisvm/dev/

Best, Angelos

comment:14 Changed 5 years ago by ian

Great - will download it tonight and do some tests

comment:15 Changed 5 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

confirmed fixed in 8.0beta1

Note: See TracTickets for help on using tickets.