Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1111 closed defect (fixed)

Mapbender on OSGeo-Live 6.5 does not load WMS - fix it by running update.sh

Reported by: astrid_emde Owned by: live-demo@…
Priority: normal Milestone:
Component: OSGeoLive Keywords: Mapbender
Cc:

Description

I noticed that Mapbender on OSGeo-Live 6.5 produces an error when loading a WMS

Looks like some updates were not successfull on installation.

Change history (5)

comment:1 Changed 6 years ago by astrid_emde

Resolution: fixed
Status: newclosed

You can fix the bug by:

cd /var/www/mapbender/resources/db
sudo chmod u+x update.sh

run update.sh on Database mapbender dbuser: user dbpassword: user
sudo ./update.sh

Now - Mapbender database should be up-to-date and can load WMS again.

comment:2 Changed 6 years ago by hamish

should this be applied to install_mapbender3.sh before closing the ticket?

note there is also a install_mapbender.sh in bin/, which is unused. One of the two should be removed, apparently it causes confusion (e.g. the fix for #1075 in r9725 a few weeks ago did not make it onto the iso build because it was applied to the deactivated* script. (* see main.sh)

thanks, Hamish

comment:3 Changed 6 years ago by astrid_emde

  • for OSGeo-Live 6.5 we still use install_mapbender.sh which installs Mapbender 2.7.3. I am not sure, why the SQLs of the install script did fail. I have to check this, but running the update.sh is a workaround to get Mapbender 2.7.3 running
  • install_mapbender3.sh is unused at the moment and will be used for OSGeo-Live 7.0 to install Mapbender3

So, for me the situation is fine for now. On OSGeo-Live 7.0 I will check Mapbender3 and Mapbender 2.7.3 will not be on OSGeo-Live anymore

comment:4 Changed 6 years ago by hamish

for OSGeo-Live 6.5 we still use install_mapbender.sh

right, my mistake. I was looking in main.sh which is not used, the list of scripts to run is inchroot.sh.

install_mapbender3.sh is unused at the moment and will be used for OSGeo-Live 7.0 to install Mapbender3

ok

Hamish

ps- any change to reduce the size of the install? (e.g. no need to ship a copy of the .deb in resources/; is test/tools/ used?; is any of the jquery development bundle stuff not needed at end-user run time, ..? the filelight program on the iso is quite good for exploring that.

comment:5 Changed 6 years ago by astrid_emde

Hamish, you are right. I can reduce the size of the install.

Note: See TracTickets for help on using tickets.